Do not try to create $localstatedir as we cannot do this when it is /var.
--- lirc-0.9.2a/daemons/Makefile.in
+++ lirc-0.9.2a/daemons/Makefile.in
@@ -790,9 +790,6 @@
uninstall-local uninstall-sbinPROGRAMS
-install-exec-local:
- test -d $(DESTDIR)$(varrundir)/$(PACKAGE) \
- || mkdir -p $(DESTDIR)$(varrundir)/$(PACKAGE)
uninstall-local:
-$(RM) $(DESTDIR)$(varrundir)/$(PACKAGE)/lircd
='2'>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2015-09-14 | doc: Use the recommended Scheme format....Apply the recommended formatting rules from '.dir-locals.el' to the
examples in the manual in order to fulfill it's purpose of being a
reference.
* doc/package-hello.scm: Indent it.
* doc/guix.texi (Defining Packages, Version Numbers): Likewise.
* gnu/packages/base.scm (hello): Be consistent with the manual.
| Mathieu Lirzin |
2015-08-19 | scripts: package: Add --install-from-file option....* guix/scripts/package.scm (show-help): Add help text for --install-from-file
option.
(%options): Add --install-from-file option.
* tests/guix-package.sh: Test it.
* doc/guix.texi ("invoking guix package"): Document it.
* doc/package-hello.scm: New file.
* doc.am (EXTRA_DIST): Add it.
| David Thompson |
d-file): Remove 'file-append'
call.
* gnu/build/linux-initrd.scm (write-cpio-archive): Check whether OUTPUT
already has the ".gz" suffix; rename if before invoking GZIP if it does,
and otherwise after.
* gnu/system/vm.scm (expression->derivation-in-linux-vm)[builder]: Do
not append "/initrd" to #$initrd.
Ludovic Courtès |
2018-11-07 | linux-initrd: Make sure 'build-initrd' can delete files....Fixes <https://bugs.gnu.org/33297>.
Reported by Mark H Weaver <mhw@netris.org>.
This fixes a regression introduced in
72dc64f8f720268930eed448abfc15d2a0eca3cf, which made files read-only.
* gnu/build/linux-initrd.scm (build-initrd): Call 'make-file-writable'
on all the files under contents/.
| Ludovic Courtès |