--- a/dcpp/CryptoManager.cpp.orig 2011-04-17 17:57:09 UTC +++ b/dcpp/CryptoManager.cpp @@ -107,12 +107,20 @@ CryptoManager::CryptoManager() }; if(dh) { - dh->p = BN_bin2bn(dh4096_p, sizeof(dh4096_p), 0); - dh->g = BN_bin2bn(dh4096_g, sizeof(dh4096_g), 0); + BIGNUM *p, *g; - if (!dh->p || !dh->g) { + p = BN_bin2bn(dh4096_p, sizeof(dh4096_p), 0); + g = BN_bin2bn(dh4096_g, sizeof(dh4096_g), 0); + + if (!p || !g) { dh.reset(); } else { +#if OPENSSL_VERSION_NUMBER < 0x10100005L + dh->p = p; + dh->g = g; +#else + DH_set0_pqg(dh, p, NULL, g); +#endif SSL_CTX_set_options(serverContext, SSL_OP_SINGLE_DH_USE); SSL_CTX_set_options(serverVerContext, SSL_OP_SINGLE_DH_USE); SSL_CTX_set_tmp_dh(serverContext, (DH*)dh); value='koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/.guix-authorizations
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-11 17:21:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-11 17:21:55 -0400
commit5ecbf5b1637762281992befec7fa53f966e5d0b1 (patch)
tree8fa0571be66035e14d625e3f6a533aad2a9e67ff /.guix-authorizations
parent6a6d9a858ef07571089f2f87466641f1374666b0 (diff)
downloadguix-5ecbf5b1637762281992befec7fa53f966e5d0b1.tar.gz
guix-5ecbf5b1637762281992befec7fa53f966e5d0b1.zip
doc: Fix cross-reference to Git Info manual.
Partially fixes <https://issues.guix.gnu.org/55821>. Partially because our git package doesn't yet include the documentation. This change will need to go to core-updates. * doc/contributing.texi (Submitting Patches): Adjust the node name.
Diffstat (limited to '.guix-authorizations')
0 files changed, 0 insertions, 0 deletions