--- a/dcpp/CryptoManager.cpp.orig 2011-04-17 17:57:09 UTC +++ b/dcpp/CryptoManager.cpp @@ -107,12 +107,20 @@ CryptoManager::CryptoManager() }; if(dh) { - dh->p = BN_bin2bn(dh4096_p, sizeof(dh4096_p), 0); - dh->g = BN_bin2bn(dh4096_g, sizeof(dh4096_g), 0); + BIGNUM *p, *g; - if (!dh->p || !dh->g) { + p = BN_bin2bn(dh4096_p, sizeof(dh4096_p), 0); + g = BN_bin2bn(dh4096_g, sizeof(dh4096_g), 0); + + if (!p || !g) { dh.reset(); } else { +#if OPENSSL_VERSION_NUMBER < 0x10100005L + dh->p = p; + dh->g = g; +#else + DH_set0_pqg(dh, p, NULL, g); +#endif SSL_CTX_set_options(serverContext, SSL_OP_SINGLE_DH_USE); SSL_CTX_set_options(serverVerContext, SSL_OP_SINGLE_DH_USE); SSL_CTX_set_tmp_dh(serverContext, (DH*)dh); n> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wicd.scm
AgeCommit message (Expand)Author
2017-09-20gnu: Use 'modify-phases' syntax....Kei Kebreau
2016-11-29gnu: wicd: Fix build....Hartmut Goebel
2016-09-28gnu: Add and use gettext-minimal....Alex Kost
2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost
2016-04-01gnu: wicd: Add template for WPA2-TTLS....Ludovic Courtès
2016-04-01gnu: wicd: Update to 1.7.4....Ludovic Courtès
2015-10-11gnu: wicd: Install 'index.theme' file in the right place....宋文武
2015-08-29gnu: Use 'install-file' instead of 'mkdir-p' and 'copy-file' in obvious cases....Ludovic Courtès
2015-08-12gnu: wicd: Fix bugs in curses interface program....Mark H Weaver
2015-05-23gnu: dbus-glib: Propagate inputs dbus and glib....Andreas Enge
2015-05-09gnu: wicd: Add patch to fix template instantiation....Ludovic Courtès