--- a/dcpp/CryptoManager.cpp.orig 2011-04-17 17:57:09 UTC
+++ b/dcpp/CryptoManager.cpp
@@ -107,12 +107,20 @@ CryptoManager::CryptoManager()
};
if(dh) {
- dh->p = BN_bin2bn(dh4096_p, sizeof(dh4096_p), 0);
- dh->g = BN_bin2bn(dh4096_g, sizeof(dh4096_g), 0);
+ BIGNUM *p, *g;
- if (!dh->p || !dh->g) {
+ p = BN_bin2bn(dh4096_p, sizeof(dh4096_p), 0);
+ g = BN_bin2bn(dh4096_g, sizeof(dh4096_g), 0);
+
+ if (!p || !g) {
dh.reset();
} else {
+#if OPENSSL_VERSION_NUMBER < 0x10100005L
+ dh->p = p;
+ dh->g = g;
+#else
+ DH_set0_pqg(dh, p, NULL, g);
+#endif
SSL_CTX_set_options(serverContext, SSL_OP_SINGLE_DH_USE);
SSL_CTX_set_options(serverVerContext, SSL_OP_SINGLE_DH_USE);
SSL_CTX_set_tmp_dh(serverContext, (DH*)dh);
n>
koszko-scripts
Wojtek's customized Guix
Age Commit message (Expand ) Author
2020-11-16 Properly deal with build directories containing '~'. ...Fixes <https://bugs.gnu.org/44626>.
Reported by Vagrant Cascadian <vagrant@debian.org>.
* tests/build-utils.scm ("wrap-script, simple case"): Pass
SCRIPT-CONTENTS to 'display' rather than 'format'.
* gnu/services/base.scm (file-system->shepherd-service-name)
[valid-characters, mount-point]: New variables.
Filter out invalid store file name characters from the mount point of
FILE-SYSTEM.
Ludovic Courtès
2019-11-26 tests: Avoid unnecessary use of 'mock'. ...* tests/build-utils.scm ("wrap-script, simple case"): Use the real
'which' instead of mocking it.
Ludovic Courtès
2019-11-26 tests: Avoid (catch 'srfi-34 …) form. ...* tests/build-utils.scm ("wrap-script, raises condition"): Use 'guard'
instead of "catch 'srfi-34".
Ludovic Courtès
2019-06-17 utils: Add 'invoke/quiet'. ...* gnu/build/bootloader.scm (G_): Remove.
(open-pipe-with-stderr, invoke/quiet): Move to...
* guix/build/utils.scm: ... here. Use 'let-values' instead of
'define-values' because Guile 2.0 (the bootstrap Guile) doesn't know
about 'define-values'.
* po/guix/POTFILES.in: Remove gnu/build/bootloader.scm, and add
guix/build/utils.scm.
* tests/build-utils.scm: Remove import of (gnu build bootloader).
Ludovic Courtès
2019-03-23 Merge branch 'staging' into core-updates Marius Bakke
2019-03-16 booloader: Add 'invoke/quiet'. ...* gnu/build/bootloader.scm (G_): New macro.
(open-pipe-with-stderr, invoke/quiet): New procedures.
* tests/build-utils.scm ("invoke/quiet, success")
("invoke/quiet, failure")
("invoke/quiet, failure, message on stderr"): New tests.
* po/guix/POTFILES.in: Add bootloader.scm.
Ludovic Courtès
2019-03-16 tests: Add 'with-environment-variable'. ...* tests/scripts.scm (with-environment-variable): Move to...
* guix/tests.scm (with-environment-variable): ... here.
* tests/build-utils.scm ("wrap-program, one input, multiple calls"):
Use it instead of 'setenv'.
Ludovic Courtès
2019-02-08 guix: Add wrap-script. ...* guix/build/utils.scm (wrap-script): New procedure.
(&wrap-error): New condition.
(wrap-error?, wrap-error-program, wrap-error-type): New procedures.
* tests/build-utils.scm ("wrap-script, simple case", "wrap-script, with
encoding declaration", "wrap-script, raises condition"): New tests.
Ricardo Wurmus