etc/committer: Teach it how to commit package removal....* etc/committer.scm.in (hunk-types): New variable.
(<hunk>): Rename hunk-definition? getter to 'hunk-type'.
(diff-info): Mute a git warning by separating file names from arguments with
'--'. Rename the 'definitions?' variable to 'type'.
Use the 'addition type when a new package addition is detected, 'removal when
removed else #f.
(add-commit-message): Re-indent.
(remove-commit-message): New procedure.
(main)[definitions]: Make commit message conditional depending on whether it
is an addition or removal.
[changes]: Adjust indentation.
Maxim Cournoyer
2022-05-31
etc/committer: Prefix (sxml xpath) symbols to avoid name conflict....This avoids a naming conflict for 'filter', provided by both (srfi srfi-1)
and (sxml xpath).
* etc/committer.scm.in: Use 'use-modules' instead of 'import', and use a
prefix for the (sxml xpath) module.
(new-sexp): Adjust accordingly.
(change-commit-message): Likewise.
Maxim Cournoyer
2022-01-23
etc: committer: Support plain input lists....* etc/committer.scm.in (change-commit-message): Support new-style plain list
inputs in addition to old-style inputs with labels.