On systems without 'setfsuid', use 'setreuid' instead. The patch originates from the Debian project for GNU/Hurd. Authors: Steve Langasek Upstream status: A ticket was opened to request apply the patch, ticket: 'https://fedorahosted.org/linux-pam/ticket/64'. --- Linux-PAM-1.2.1/libpam/pam_modutil_priv.c 2015-03-24 06:02:32.000000000 -0600 +++ pam_modutil_priv-mod.c 2016-09-20 13:36:53.150663205 -0500 @@ -14,7 +14,9 @@ #include #include #include +#ifdef HAVE_SYS_FSUID_H #include +#endif /* HAVE_SYS_FSUID_H */ /* * Two setfsuid() calls in a row are necessary to check @@ -22,17 +24,55 @@ */ static int change_uid(uid_t uid, uid_t *save) { +#ifdef HAVE_SYS_FSUID_H uid_t tmp = setfsuid(uid); if (save) *save = tmp; return (uid_t) setfsuid(uid) == uid ? 0 : -1; +#else + uid_t euid = geteuid(); + uid_t ruid = getuid(); + if (save) + *save = ruid; + if (ruid == uid && uid != 0) + if (setreuid(euid, uid)) + return -1; + else { + setreuid(0, -1); + if (setreuid(-1, uid)) { + setreuid(-1, 0); + setreuid(0, -1); + if (setreuid(-1, uid)) + return -1; + } + } +#endif } static int change_gid(gid_t gid, gid_t *save) { +#ifdef HAVE_SYS_FSUID_H gid_t tmp = setfsgid(gid); if (save) *save = tmp; return (gid_t) setfsgid(gid) == gid ? 0 : -1; +#else + gid_t egid = getegid(); + gid_t rgid = getgid(); + if (save) + *save = rgid; + if (rgid == gid) + if (setregid(egid, gid)) + return -1; + else { + setregid(0, -1); + if (setregid(-1, gid)) { + setregid(-1, 0); + setregid(0, -1); + if (setregid(-1, gid)) + return -1; + } + } +#endif } static int cleanup(struct pam_modutil_privs *p) ption value='range'>range
path: root/NEWS
AgeCommit message (Expand)Author
2018-12-05Update NEWS.Ludovic Courtès
2018-12-05Update NEWS.Ludovic Courtès
2018-11-23Update NEWS.Ludovic Courtès
2018-08-30Update NEWS.Ricardo Wurmus
2018-07-05Update NEWS.Ludovic Courtès
2018-07-05Update NEWS.Ludovic Courtès
2018-06-20Update NEWS.Ludovic Courtès
2018-05-29Update NEWS.Ricardo Wurmus
2018-05-20services: Add Enlightenment desktop service....* gnu/services/desktop.scm (<enlightenment-desktop-configuration>, enlightenment-desktop-service-type): New variables. * doc/guix.texi (Desktop Services): Document the service. * NEWS: Mention it. Efraim Flashner
2018-05-08guix: Separate the package name and version with "@", not "-"....* guix/packages.scm (package-full-name): By default, use "@" to separate the package name and package version. Add an optional delimiter argument so that there is still a way to explicitly use a different delimiter. * gnu/packages/commencement.scm (gcc-boot0) <unpack-gmp&co>: Adjust accordingly. * tests/graph.scm: Adjust accordingly. * tests/profiles.scm: Adjust accordingly. * NEWS: Mention the change. Fixes: <https://bugs.gnu.org/31088>. Reported by Pierre Neidhardt <ambrevar@gmail.com>. Chris Marusich
2017-12-06Update NEWS.Ludovic Courtès
2017-12-06Update NEWS.Ludovic Courtès
2017-12-05Update NEWS.Ludovic Courtès
2017-12-04Update NEWS.Ludovic Courtès
2017-05-22Update NEWS.Ludovic Courtès
2017-05-21Update NEWS.Ludovic Courtès
2017-05-20Update NEWS.Ricardo Wurmus
2017-05-17Update NEWS.Ricardo Wurmus
2017-05-16Update NEWS.Ludovic Courtès
2016-12-20Update NEWS....Co-authored-by: Ludovic Courtès <ludo@gnu.org> Ricardo Wurmus