When providing the VNCServer command as 'Xvnc -SecurityTypes None',
the formatted command line used would look like:
Xvnc -SecurityTypes None :1 -auth /var/run/lightdm/root/:1
which is invalid (the display number must appear first).
Submitted upstream at: https://github.com/canonical/lightdm/pull/265
src/x-server-local.c | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
diff --git a/src/x-server-local.c b/src/x-server-local.c
index 7c4ab870..6c540d18 100644
--- a/src/x-server-local.c
+++ b/src/x-server-local.c
@@ -463,14 +463,20 @@ x_server_local_start (DisplayServer *display_server)
l_debug (display_server, "Logging to %s", log_file);
g_autofree gchar *absolute_command = get_absolute_command (priv->command);
+ g_auto(GStrv) tokens = g_strsplit (absolute_command, " ", 2);
+ const gchar* binary = tokens[0];
+ const gchar *extra_options = tokens[1];
+
if (!absolute_command)
{
l_debug (display_server, "Can't launch X server %s, not found in path", priv->command);
stopped_cb (priv->x_server_process, X_SERVER_LOCAL (server));
return FALSE;
}
- g_autoptr(GString) command = g_string_new (absolute_command);
+ g_autoptr(GString) command = g_string_new (binary);
+ /* The display argument must be given first when the X server used
+ * is Xvnc. */
g_string_append_printf (command, " :%d", priv->display_number);
if (priv->config_file)
@@ -513,6 +519,12 @@ x_server_local_start (DisplayServer *display_server)
if (X_SERVER_LOCAL_GET_CLASS (server)->add_args)
X_SERVER_LOCAL_GET_CLASS (server)->add_args (server, command);
+ /* Any extra user options provided via the VNCServer 'command'
+ * config option are appended last, so the user can override any
+ * of the above. */
+ if (extra_options)
+ g_string_append_printf (command, " %s", extra_options);
+
process_set_command (priv->x_server_process, command->str);
l_debug (display_server, "Launching X Server");
--
2.36.1
fb1dc15132ed5aa38b0978b4c9e8751c5'>bootstrap
Age | Commit message (Expand) | Author |
2024-04-19 | maint: Generate doc/version[-LANG].texi using `mdate-from-git.scm'....This replaces Automake's `build-aux/mdate-sh' with our own
`build-aux/mdate-from-git.scm' to use reproducible timestamps from Git
instead.
* build-aux/mdate-from-git.scm: New script.
* bootstrap: Use it to replace build-aux/mdate-sh.
* Makefile.am (EXTRA_DIST): Add it.
Change-Id: I17d0a7de9ffea397129c0db1728f86e28a4e245f
| Janneke Nieuwenhuizen |
2021-06-13 | bootstrap: Simplify search for translation languages....Extend the sed script to also behave like "basename",
saving the addtional call of "xargs basename".
* bootstrap (langs): Extend sed scripts, remove running xargs.
| Hartmut Goebel |
2020-02-17 | bootstrap: Fix typo....* bootstrap: Substitute ‘guix-cookbook’ for copy/pasted ‘guix-manual’.
Reported-by: jetomit on #guix
| Tobias Geerinckx-Rice |
2019-09-18 | doc: Add Guix Cookbook....* .gitignore: Update ignore list.
* Makefile.am (assert-no-store-file-names): Exclude the cookbook.
* bootstrap: Generate po files for cookbook translations.
* doc/guix-cookbook.texi: New file.
* doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook
translations.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable.
(EXTRA_DIST): Add cookbook pot file and po files.
(doc-po-update-cookbook-%): New target.
(doc-pot-update): Also update cookbook pot file.
(doc-po-update): Also update cookbook po files.
| Ricardo Wurmus |