Copied from Fedora. http://pkgs.fedoraproject.org/cgit/libwmf.git/tree/libwmf-0.2.8.4-CVE-2007-3477.patch --- libwmf-0.2.8.4/src/extra/gd/gd.c +++ libwmf-0.2.8.4/src/extra/gd/gd.c @@ -1335,10 +1335,31 @@ int w2, h2; w2 = w / 2; h2 = h / 2; - while (e < s) - { - e += 360; - } + + if ((s % 360) == (e % 360)) { + s = 0; e = 360; + } else { + if (s > 360) { + s = s % 360; + } + + if (e > 360) { + e = e % 360; + } + + while (s < 0) { + s += 360; + } + + while (e < s) { + e += 360; + } + + if (s == e) { + s = 0; e = 360; + } + } + for (i = s; (i <= e); i++) { int x, y; ption> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
AgeCommit message (Expand)Author
2017-02-13Merge branch 'master' into python-testsMarius Bakke
2017-01-13gnu: openvpn: Update to 2.4.0....Julien Lepiller
2017-01-13Merge branch 'master' into python-testsLeo Famulari
2017-01-02gnu: openvpn: Update to 2.3.14....Efraim Flashner
2016-12-19gnu: sshoot: Fix tests....Marius Bakke
2016-12-15gnu: openconnect: Update to 7.08....Tobias Geerinckx-Rice
2016-12-11gnu: Add sshoot....Tobias Geerinckx-Rice
2016-12-11gnu: Add sshuttle....Tobias Geerinckx-Rice
2016-11-15gnu: gvpe: Update to 3.0....Efraim Flashner
2016-10-23Merge branch 'master' into core-updatesMark H Weaver
2016-10-23gnu: openconnect: Update to 7.07....Tobias Geerinckx-Rice
2016-09-28gnu: Add and use gettext-minimal....Alex Kost