Patch contents copied from Mozilla esr45 changeset 312077:7ebfe49f001c changeset: 312077:7ebfe49f001c user: Randell Jesup Date: Fri Apr 15 23:11:01 2016 -0400 summary: Bug 1263384: validate input frames against configured resolution in vp8 r=rillian, a=ritu,lizzard MozReview-Commit-ID: BxDCnJe0mzs --- libvpx-1.5.0/vp8/vp8_cx_iface.c.orig 2015-11-09 17:12:38.000000000 -0500 +++ libvpx-1.5.0/vp8/vp8_cx_iface.c 2016-06-08 08:48:46.037213092 -0400 @@ -860,11 +860,20 @@ if (img != NULL) { res = image2yuvconfig(img, &sd); - if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags, &sd, - dst_time_stamp, dst_end_time_stamp)) { - VP8_COMP *cpi = (VP8_COMP *)ctx->cpi; - res = update_error_state(ctx, &cpi->common.error); - } + if (sd.y_width != ctx->cfg.g_w || sd.y_height != ctx->cfg.g_h) { + /* from vp8_encoder.h for g_w/g_h: + "Note that the frames passed as input to the encoder must have this resolution" + */ + ctx->base.err_detail = "Invalid input frame resolution"; + res = VPX_CODEC_INVALID_PARAM; + } else { + if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags, + &sd, dst_time_stamp, dst_end_time_stamp)) + { + VP8_COMP *cpi = (VP8_COMP *)ctx->cpi; + res = update_error_state(ctx, &cpi->common.error); + } + } /* reset for next frame */ ctx->next_frame_flag = 0; 18b3c'/>
path: root/tests/read-print.scm
AgeCommit message (Expand)Author
2022-09-20read-print: Correctly support multiple same-named newline forms....Ludovic Courtès
2022-09-02read-print: Define forms for which \n, \t, etc. are not escaped....Ludovic Courtès
2022-09-01read-print: Guess the base to use for integers being printed....Ludovic Courtès
2022-08-10read-print: Report missing closing parens instead of looping....Ludovic Courtès
2022-08-08read-print: Add 'case' and 'cond' special forms....Ludovic Courtès
2022-08-08read-print: Support printing multi-line comments....Ludovic Courtès
2022-08-08read-print: 'canonicalize-comment' leaves top-level comments unchanged....Ludovic Courtès
2022-08-08read-print: Add code to read and write sequences of expressions/blanks....Ludovic Courtès
2022-08-08read-print: Recognize page breaks....Ludovic Courtès
2022-08-08read-print: Read and render vertical space....Ludovic Courtès
2022-08-08style: Move reader and printer to (guix read-print)....Ludovic Courtès