Patch contents copied from Mozilla esr45 changeset 312077:7ebfe49f001c changeset: 312077:7ebfe49f001c user: Randell Jesup Date: Fri Apr 15 23:11:01 2016 -0400 summary: Bug 1263384: validate input frames against configured resolution in vp8 r=rillian, a=ritu,lizzard MozReview-Commit-ID: BxDCnJe0mzs --- libvpx-1.5.0/vp8/vp8_cx_iface.c.orig 2015-11-09 17:12:38.000000000 -0500 +++ libvpx-1.5.0/vp8/vp8_cx_iface.c 2016-06-08 08:48:46.037213092 -0400 @@ -860,11 +860,20 @@ if (img != NULL) { res = image2yuvconfig(img, &sd); - if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags, &sd, - dst_time_stamp, dst_end_time_stamp)) { - VP8_COMP *cpi = (VP8_COMP *)ctx->cpi; - res = update_error_state(ctx, &cpi->common.error); - } + if (sd.y_width != ctx->cfg.g_w || sd.y_height != ctx->cfg.g_h) { + /* from vp8_encoder.h for g_w/g_h: + "Note that the frames passed as input to the encoder must have this resolution" + */ + ctx->base.err_detail = "Invalid input frame resolution"; + res = VPX_CODEC_INVALID_PARAM; + } else { + if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags, + &sd, dst_time_stamp, dst_end_time_stamp)) + { + VP8_COMP *cpi = (VP8_COMP *)ctx->cpi; + res = update_error_state(ctx, &cpi->common.error); + } + } /* reset for next frame */ ctx->next_frame_flag = 0; f31f7'/>
path: root/gnu/packages/vpn.scm
AgeCommit message (Expand)Author
2018-06-22gnu: vpnc-scripts: Update to 20180226.07c3518....Tobias Geerinckx-Rice
2018-06-22gnu: vpnc-scripts: Return #t from all phases....Tobias Geerinckx-Rice
2018-04-30Merge branch 'master' into core-updatesMark H Weaver
2018-04-26gnu: openvpn: Update to 2.4.6....Tobias Geerinckx-Rice
2018-04-22gnu: Add ocproxy....Pierre Langlois
2018-04-10Merge branch 'master' into core-updatesMark H Weaver
2018-04-05gnu: sshuttle: Update to 0.78.4....Tobias Geerinckx-Rice
2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver
2018-03-13gnu: vpnc-scripts: Declare a source file-name....Efraim Flashner
2018-03-05gnu: openvpn: Mark up description....Tobias Geerinckx-Rice
2018-03-05gnu: openvpn: Update to 2.4.5....Tobias Geerinckx-Rice
2018-02-26gnu: tinc: Update to 1.0.33....Tobias Geerinckx-Rice