Patch contents copied from Mozilla esr45 changeset 312077:7ebfe49f001c changeset: 312077:7ebfe49f001c user: Randell Jesup Date: Fri Apr 15 23:11:01 2016 -0400 summary: Bug 1263384: validate input frames against configured resolution in vp8 r=rillian, a=ritu,lizzard MozReview-Commit-ID: BxDCnJe0mzs --- libvpx-1.5.0/vp8/vp8_cx_iface.c.orig 2015-11-09 17:12:38.000000000 -0500 +++ libvpx-1.5.0/vp8/vp8_cx_iface.c 2016-06-08 08:48:46.037213092 -0400 @@ -860,11 +860,20 @@ if (img != NULL) { res = image2yuvconfig(img, &sd); - if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags, &sd, - dst_time_stamp, dst_end_time_stamp)) { - VP8_COMP *cpi = (VP8_COMP *)ctx->cpi; - res = update_error_state(ctx, &cpi->common.error); - } + if (sd.y_width != ctx->cfg.g_w || sd.y_height != ctx->cfg.g_h) { + /* from vp8_encoder.h for g_w/g_h: + "Note that the frames passed as input to the encoder must have this resolution" + */ + ctx->base.err_detail = "Invalid input frame resolution"; + res = VPX_CODEC_INVALID_PARAM; + } else { + if (vp8_receive_raw_frame(ctx->cpi, ctx->next_frame_flag | lib_flags, + &sd, dst_time_stamp, dst_end_time_stamp)) + { + VP8_COMP *cpi = (VP8_COMP *)ctx->cpi; + res = update_error_state(ctx, &cpi->common.error); + } + } /* reset for next frame */ ctx->next_frame_flag = 0; on value='author'>author
path: root/.gitignore
AgeCommit message (Expand)Author
2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus
2019-04-26bootstrap: Break automake dependency on generated files....Miguel Ángel Arruga Vivas
2018-11-20.gitignore: Re-add 'authenticate' script....Marius Bakke
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-12.gitignore: Add doc/stamp-[0-9].Ludovic Courtès
2018-04-19gnu: doc: Allow documentation to be translated....Julien Lepiller
2018-02-13.gitignore: Add guix-daemon SELinux policy....Efraim Flashner
2017-05-13.gitignore: Ignore Emacs auto-save files....ng0
2017-05-08build: Add doc/guix.html to .gitignore....Clément Lassieur
2017-05-04build: Use Gnulib's 'git-version-gen'....Ludovic Courtès