From 18e3ff648356cf06a39372aa4a4bbf2732d9d0f4 Mon Sep 17 00:00:00 2001 From: Efraim Flashner Date: Tue, 12 Dec 2017 21:36:44 +0200 Subject: [PATCH] don't use bundled libvdpau headers --- CMakeLists.txt | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/CMakeLists.txt b/CMakeLists.txt index 0484179..e950707 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -9,16 +9,17 @@ find_package(PkgConfig REQUIRED) find_package(X11 REQUIRED) pkg_check_modules(LIBVA libva-x11 REQUIRED) pkg_check_modules(LIBGL gl REQUIRED) +pkg_check_modules(LIBVDPAU vdpau REQUIRED) set(DRIVER_NAME "vdpau_va_gl" CACHE STRING "driver name") set(LIB_SUFFIX "" CACHE STRING "library path suffix (if needed)") set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/vdpau" CACHE PATH "library installation path") include_directories ( - 3rdparty ${X11_INCLUDE_DIRS} ${LIBVA_INCLUDE_DIRS} ${LIBGL_INCLUDE_DIRS} + ${LIBVDPAU_INCLUDE_DIRS} ${GENERATED_INCLUDE_DIRS} ${CMAKE_BINARY_DIR} ) -- 2.15.1 r> aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/security-token.scm
AgeCommit message (Collapse)Author
2023-12-22services: Remove unnecessary references to (gnu build shepherd).Ludovic Courtès
* gnu/services/databases.scm (memcached-shepherd-service): Remove ‘with-imported-modules’ form and ‘modules’ field. * gnu/services/security-token.scm (pcscd-shepherd-service): Remove ‘with-imported-modules’ form. * gnu/services/web.scm (hpcguix-web-shepherd-service): Likewise. Change-Id: Ieb817508f1751e0c1ff551a0e078789a4a813c1c
2022-06-25services: pcscd: Use switch-symlinks from (guix build utils).Arun Isaac
switch-symlinks has been moved to (guix build utils). We need not duplicate it anymore. * gnu/services/security-token.scm (pcscd-activation): Use switch-symlinks from (guix build utils).
2021-07-03services: pcscd: Fix daemon signal handling.Brice Waegeneire
"pcscd" wouldn't handle SIGTERM as it inherit ignoring this signal (and others) from its parent shepherd; fork+exec-command restore signal handling. Fixes <https://issues.guix.gnu.org/45202>. * gnu/services/security-token.scm (pcscd)[start]: Use fork+exec-command to start "pcscd".
2021-06-19services: pcscd: Cleanup socket when started.Brice Waegeneire
Otherwise when pcscd doesn't terminate properly (ie. receive a SIGKILL), it won't start again because of it's socket already existing. * gnu/services/security-token.scm (pcscd-shepherd-service)[start]: Remove existing socket file.
2020-12-13gnu: htop: Update to 3.0.3.Tobias Geerinckx-Rice
* gnu/packages/admin.scm (htop): Update to 3.0.3.
2020-12-12services: pcscd-shepherd-service: Fix PID file location.Tobias Geerinckx-Rice
Fixes <http://issues.guix.gnu.org/45202>. * gnu/services/security-token.scm (pcscd-shepherd-service): Look for pcscd.pid in /run instead of /var/run. Reported by Raffael Stocker <r.stocker@mnet-mail.de>.