Minimally patch libtheora's ancient config.guess to support mips64.
--- libtheora/config.guess.orig 2009-02-23 22:50:50.000000000 -0500
+++ libtheora/config.guess 2013-10-31 23:49:48.155999944 -0400
@@ -798,25 +798,24 @@
m68*:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-gnu
exit 0 ;;
- mips:Linux:*:*)
+ mips:Linux:*:* | mips64:Linux:*:*)
eval $set_cc_for_build
sed 's/^ //' << EOF >$dummy.c
#undef CPU
- #undef mips
- #undef mipsel
+ #undef ${UNAME_MACHINE}
+ #undef ${UNAME_MACHINE}el
#if defined(__MIPSEL__) || defined(__MIPSEL) || defined(_MIPSEL) || defined(MIPSEL)
- CPU=mipsel
+ CPU=${UNAME_MACHINE}el
#else
#if defined(__MIPSEB__) || defined(__MIPSEB) || defined(_MIPSEB) || defined(MIPSEB)
- CPU=mips
+ CPU=${UNAME_MACHINE}
#else
CPU=
#endif
#endif
EOF
- eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
- rm -f $dummy.c && rmdir $tmpdir
- test x"${CPU}" != x && echo "${CPU}-pc-linux-gnu" && exit 0
+ eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^CPU'`
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit 0; }
;;
ppc:Linux:*:*)
echo powerpc-unknown-linux-gnu
s/?id=e1d2c2c8699ef03b1e68d8846b4a57bcacb1be55'>refslogtreecommitdiff
gnu: aardvark-dns: Update to 1.12.2.
* gnu/packages/rust-apps.scm (aardvark-dns): Update to 1.12.2.
[cargo-inputs]: Add rust-arc-swap-1, rust-flume-0.11. Replace
rust-nix-0.27 with 0.29, rust-syslog-6 with 7. Remove rust-anyhow-1,
rust-async-broadcast-0.6, rust-signal-hook-0.3.
Change-Id: I25d12567aed47b28464a4236ca72c3e1a44557f4
0 files changed, 0 insertions, 0 deletions