Minimally patch libtheora's ancient config.guess to support mips64.
--- libtheora/config.guess.orig 2009-02-23 22:50:50.000000000 -0500
+++ libtheora/config.guess 2013-10-31 23:49:48.155999944 -0400
@@ -798,25 +798,24 @@
m68*:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-gnu
exit 0 ;;
- mips:Linux:*:*)
+ mips:Linux:*:* | mips64:Linux:*:*)
eval $set_cc_for_build
sed 's/^ //' << EOF >$dummy.c
#undef CPU
- #undef mips
- #undef mipsel
+ #undef ${UNAME_MACHINE}
+ #undef ${UNAME_MACHINE}el
#if defined(__MIPSEL__) || defined(__MIPSEL) || defined(_MIPSEL) || defined(MIPSEL)
- CPU=mipsel
+ CPU=${UNAME_MACHINE}el
#else
#if defined(__MIPSEB__) || defined(__MIPSEB) || defined(_MIPSEB) || defined(MIPSEB)
- CPU=mips
+ CPU=${UNAME_MACHINE}
#else
CPU=
#endif
#endif
EOF
- eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
- rm -f $dummy.c && rmdir $tmpdir
- test x"${CPU}" != x && echo "${CPU}-pc-linux-gnu" && exit 0
+ eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^CPU'`
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit 0; }
;;
ppc:Linux:*:*)
echo powerpc-unknown-linux-gnu
3a91a841cf056103'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-09-06 | gnu: Remove python-typing-extensions-4.10....* gnu/packages/machine-learning.scm (python-typing-extensions-4.10): Delete
variable.
* gnu/packages/machine-learning.scm (python-pytorch)[native-inputs] Replace
python-typing-extensions-4.10 with python-typing-extensions.
| David Elsing |
2024-08-31 | gnu: python-pip: Ungraft....* gnu/packages/python-build.scm (python-pip): Ungraft and apply source snippet
directly.
(python-pip/fixed): Remove variable.
Change-Id: I4913e8f87f5934bffec9d58ad86b97f8ca16ba32
| Josselin Poiret |
2024-07-30 | gnu: Add python-pluggy-next....* gnu/packages/python-build.scm (python-pluggy-next): New variable.
Change-Id: If3ec3f930a799df9602db71112a6c6a5272b524c
| Sharlatan Hellseher |
2024-06-18 | gnu: Add python-typing-extensions-4.10....* gnu/packages/python-build.scm (python-typing-extensions-4.10): New variable.
| David Elsing |
2024-04-07 | gnu: python-pip: Use system SSL certificates....* gnu/packages/python-build.scm (python-pip)[replacement]: New
field.
(python-pip/fixed): Provide a python-pip with a patched python-certifi
which only offers to use the system's SSL certificates.
Change-Id: Icea0769b881dc8d760562f0405fa8ea8167a4bd4
| Efraim Flashner |
2024-02-20 | gnu: python-typing-extensions: Update to 4.9.0....* gnu/packages/python-build.scm (python-typing-extensions): Update to 4.9.0.
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
| Hartmut Goebel |