Fix "Hostname" parsing in OpenSSH config files, as reported at . From: Niels Ole Salscheider Date: Mon, 8 May 2017 17:36:13 +0200 Subject: [PATCH] Fix reading of the first parameter This is a fixup for 7b8b5eb4eac314a3a29be812bef0264c6611f6e7. Previously, it would return as long as the parameter was _not_ seen before. It also did not handle the case for the unsupported opcode (-1) which would cause a segfault when accessing the "seen" array. --- src/config.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/src/config.c b/src/config.c index 7c03b27..238a655 100644 --- a/src/config.c +++ b/src/config.c @@ -218,8 +218,9 @@ static int ssh_config_parse_line(ssh_session session, const char *line, } opcode = ssh_config_get_opcode(keyword); - if (*parsing == 1 && opcode != SOC_HOST) { - if (seen[opcode] == 0) { + if (*parsing == 1 && opcode != SOC_HOST && + opcode > SOC_UNSUPPORTED && opcode < SOC_END) { + if (seen[opcode] == 1) { return 0; } seen[opcode] = 1; 6dc88bccaa2ead0ba5500e7e46'>refslogtreecommitdiff
AgeCommit message (Expand)Author
2018-06-14gnu: sssd: Update to 1.16.2....Tobias Geerinckx-Rice
2018-03-11gnu: sssd: Update to 1.16.1....Tobias Geerinckx-Rice
2017-11-04gnu: sssd: Disable failing test....Marius Bakke
2017-10-25gnu: sssd: Add missing word to description....Tobias Geerinckx-Rice
2017-10-25gnu: sssd: Update to 1.16.0....Tobias Geerinckx-Rice
2017-10-25gnu: ding-libs: Update to 0.6.1....Tobias Geerinckx-Rice
2017-07-29gnu: sssd: Update to 1.15.3....Tobias Geerinckx-Rice
2017-05-16gnu: bind: Rename variable to 'isc-bind'....Ludovic Courtès
2017-05-15gnu: Add sssd....Ricardo Wurmus
2017-05-15gnu: Add ding-libs....Ricardo Wurmus