Fix "Hostname" parsing in OpenSSH config files, as reported at . From: Niels Ole Salscheider Date: Mon, 8 May 2017 17:36:13 +0200 Subject: [PATCH] Fix reading of the first parameter This is a fixup for 7b8b5eb4eac314a3a29be812bef0264c6611f6e7. Previously, it would return as long as the parameter was _not_ seen before. It also did not handle the case for the unsupported opcode (-1) which would cause a segfault when accessing the "seen" array. --- src/config.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/src/config.c b/src/config.c index 7c03b27..238a655 100644 --- a/src/config.c +++ b/src/config.c @@ -218,8 +218,9 @@ static int ssh_config_parse_line(ssh_session session, const char *line, } opcode = ssh_config_get_opcode(keyword); - if (*parsing == 1 && opcode != SOC_HOST) { - if (seen[opcode] == 0) { + if (*parsing == 1 && opcode != SOC_HOST && + opcode > SOC_UNSUPPORTED && opcode < SOC_END) { + if (seen[opcode] == 1) { return 0; } seen[opcode] = 1; ea97de3745804881d7446d34'>refslogtreecommitdiff
AgeCommit message (Expand)Author
2019-03-30gnu: gtk+: Graft upstream fix for crashes in Emacs and IceCat....Mark H Weaver
2019-03-18gnu: gtksourceview: Update to 3.24.10....Tobias Geerinckx-Rice
2019-03-18gnu: gtksourceview: Don't use NAME in source URI....Tobias Geerinckx-Rice
2019-03-18Correct name and email address for ng0....ng0
2019-02-17gnu: clipit: Update to 1.4.4....Tobias Geerinckx-Rice
2019-02-17gnu: yad: Update to 0.41.0....Tobias Geerinckx-Rice
2019-01-31Merge branch 'master' into stagingMarius Bakke
2019-01-28gnu: Move most packages from guile.scm to new module....Ricardo Wurmus
2019-01-20Merge branch 'master' into stagingLudovic Courtès
2019-01-18gnu: graphene: Remove custom autogen phase....Ricardo Wurmus
2019-01-15gnu: Separate Python core packages from the rest....Ricardo Wurmus