diff --git a/scripts/librewolf-patches.py b/scripts/librewolf-patches.py
index 48dc6bc..01a6c58 100755
--- a/scripts/librewolf-patches.py
+++ b/scripts/librewolf-patches.py
@@ -147,12 +147,6 @@ def librewolf_patches():
with open(file, "w") as f:
f.write("{}-{}".format(version,release))
- print("-> Downloading locales from https://github.com/mozilla-l10n/firefox-l10n")
- with TemporaryDirectory() as tmpdir:
- exec(f"wget -qO {tmpdir}/l10n.zip 'https://codeload.github.com/mozilla-l10n/firefox-l10n/zip/refs/heads/main'")
- exec(f"unzip -qo {tmpdir}/l10n.zip -d {tmpdir}/l10n")
- exec(f"mv {tmpdir}/l10n/firefox-l10n-main lw/l10n")
-
print("-> Patching appstrings.properties")
# Why is "Firefox" hardcoded there???
exec("find . -path '*/appstrings.properties' -exec sed -i s/Firefox/LibreWolf/ {} \;")
lass='sub'>Wojtek's customized Guix
|
Age | Commit message (Expand) | Author |
2024-04-19 | maint: Generate doc/version[-LANG].texi using `mdate-from-git.scm'....This replaces Automake's `build-aux/mdate-sh' with our own
`build-aux/mdate-from-git.scm' to use reproducible timestamps from Git
instead.
* build-aux/mdate-from-git.scm: New script.
* bootstrap: Use it to replace build-aux/mdate-sh.
* Makefile.am (EXTRA_DIST): Add it.
Change-Id: I17d0a7de9ffea397129c0db1728f86e28a4e245f
| Janneke Nieuwenhuizen |
2021-06-13 | bootstrap: Simplify search for translation languages....Extend the sed script to also behave like "basename",
saving the addtional call of "xargs basename".
* bootstrap (langs): Extend sed scripts, remove running xargs.
| Hartmut Goebel |