diff --git a/scripts/librewolf-patches.py b/scripts/librewolf-patches.py
index 48dc6bc..01a6c58 100755
--- a/scripts/librewolf-patches.py
+++ b/scripts/librewolf-patches.py
@@ -147,12 +147,6 @@ def librewolf_patches():
with open(file, "w") as f:
f.write("{}-{}".format(version,release))
- print("-> Downloading locales from https://github.com/mozilla-l10n/firefox-l10n")
- with TemporaryDirectory() as tmpdir:
- exec(f"wget -qO {tmpdir}/l10n.zip 'https://codeload.github.com/mozilla-l10n/firefox-l10n/zip/refs/heads/main'")
- exec(f"unzip -qo {tmpdir}/l10n.zip -d {tmpdir}/l10n")
- exec(f"mv {tmpdir}/l10n/firefox-l10n-main lw/l10n")
-
print("-> Patching appstrings.properties")
# Why is "Firefox" hardcoded there???
exec("find . -path '*/appstrings.properties' -exec sed -i s/Firefox/LibreWolf/ {} \;")
>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-08-21 | maint: Add 'etc/hurd-manifest.scm'....* build-aux/cuirass/hurd-manifest.scm: Move to...
* etc/hurd-manifest.scm: ...here.
* Makefile.am (EXTRA_DIST): Update accordingly.
| Janneke Nieuwenhuizen |
2023-07-25 | cuirass: Update hurd-manifest with newly supported packages....* build-aux/cuirass/hurd-manifest.scm: Include full build of python-minimal
and gettext-minimal (no longer without-tests). Add grub-minimal, grub,
guix-without-tests and guile-3.0 (no longer delete it from guix dependencies).
| Janneke Nieuwenhuizen |
2022-05-26 | cuirass: Create just as many threads as needed....* build-aux/cuirass/evaluate.scm (command-line): Change second argument
to 'n-par-for-each'.
| Ludovic Courtès |
2022-05-26 | cuirass: Fork inferior processes before creating threads....Works around <https://issues.guix.gnu.org/55441#12>.
Start from commit bd86bbd300474204878e927f6cd3f0defa1662a5,
'open-inferior' uses 'primitive-fork' instead of 'open-pipe*'. As a
result, child process could potentially hang before calling 'execl' due
to undefined behavior when forking a multi-threaded process.
* build-aux/cuirass/evaluate.scm <top level>: Call 'open-inferior'
before 'n-par-for-each'.
| Ludovic Courtès |
2022-05-20 | cuirass: Close each inferior upon completion....* build-aux/cuirass/evaluate.scm <top level>: Add 'close-inferior' call.
| Ludovic Courtès |