Set visibility of global symbols used in ARM specific assembly file to
internal.
Taken from Debian:
https://salsa.debian.org/multimedia-team/mpeg2dec/blob/master/debian/patches/60_arm-private-symbols.patch
--- mpeg2dec.orig/libmpeg2/motion_comp_arm_s.S
+++ mpeg2dec/libmpeg2/motion_comp_arm_s.S
@@ -23,7 +23,8 @@
@ ----------------------------------------------------------------
.align
- .global MC_put_o_16_arm
+ .global MC_put_o_16_arm
+ .internal MC_put_o_16_arm
MC_put_o_16_arm:
@@ void func(uint8_t * dest, const uint8_t * ref, int stride, int height)
pld [r1]
@@ -83,7 +84,8 @@ MC_put_o_16_arm_align_jt:
@ ----------------------------------------------------------------
.align
- .global MC_put_o_8_arm
+ .global MC_put_o_8_arm
+ .internal MC_put_o_8_arm
MC_put_o_8_arm:
@@ void func(uint8_t * dest, const uint8_t * ref, int stride, int height)
pld [r1]
@@ -152,7 +154,8 @@ MC_put_o_8_arm_align_jt:
.endm
.align
- .global MC_put_x_16_arm
+ .global MC_put_x_16_arm
+ .internal MC_put_x_16_arm
MC_put_x_16_arm:
@@ void func(uint8_t * dest, const uint8_t * ref, int stride, int height)
pld [r1]
@@ -244,7 +247,8 @@ MC_put_x_16_arm_align_jt:
@ ----------------------------------------------------------------
.align
- .global MC_put_x_8_arm
+ .global MC_put_x_8_arm
+ .internal MC_put_x_8_arm
MC_put_x_8_arm:
@@ void func(uint8_t * dest, const uint8_t * ref, int stride, int height)
pld [r1]
e'>commitdiff
|
Age | Commit message (Expand) | Author |
2023-09-22 | gnu: barectf: Update to 3.1.2....* gnu/packages/instrumentation.scm (barectf): Update to 3.1.2.
[source]: Switch to GIT-FETCH.
[build-system]: Change to PYPROJECT-BUILD-SYSTEM.
[arguments]: Remove version pins. Set CC before building.
[native-inputs]: Add PYTHON-POETRY-CORE and PYTHON-PYTEST. Remove
GCC-TOOLCHAIN, GNU-MAKE, PYTHON-PYYAML-5, and PYTHON-TOX. Move PYTHON-JINJA2,
PYTHON-JSONSCHEMA, and PYTHON-TERMCOLOR ...
[propagated-inputs]: ... here. Add PYTHON-PYYAML.
| Marius Bakke |
2023-08-20 | gnu: lttng-ust: Update to 2.13.6....* gnu/packages/instrumentation.scm (lttng-ust): Update to 2.13.6.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| fanquake |