From 109fef8208188ddf4be76d6899f7d8fde5b8b3be Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= Date: Sat, 22 Jul 2023 14:40:31 +0800 Subject: [PATCH] Use TZDIR for ZONEINFO_DIR if the variable is set. --- libmateweather/mateweather-timezone.c | 8 +++++--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a/libmateweather/mateweather-timezone.c b/libmateweather/mateweather-timezone.c index 2754728..6c858c4 100644 --- a/libmateweather/mateweather-timezone.c +++ b/libmateweather/mateweather-timezone.c @@ -61,7 +61,7 @@ static gboolean parse_tzdata (const char *tzname, time_t start, time_t end, int *offset, gboolean *has_dst, int *dst_offset) { - char *filename, *contents; + char *tzdir, *filename, *contents; gsize length; int timecnt, transitions_size, ttinfo_map_size; int initial_transition = -1, second_transition = -1; @@ -71,7 +71,10 @@ parse_tzdata (const char *tzname, time_t start, time_t end, char initial_isdst, second_isdst; int i; - filename = g_build_filename (ZONEINFO_DIR, tzname, NULL); + tzdir = g_getenv("TZDIR"); + if (tzdir == NULL) + tzdir = ZONEINFO_DIR; + filename = g_build_filename (tzdir, tzname, NULL); if (!g_file_get_contents (filename, &contents, &length, NULL)) { g_free (filename); return FALSE; @@ -403,4 +406,3 @@ mateweather_timezone_get_dst_offset (MateWeatherTimezone *zone) g_return_val_if_fail (zone->has_dst, 0); return zone->dst_offset; } - -- 2.41.0 put type='hidden' name='id' value='028959236dee5e2f851218ea6418675531b400cd'/>
path: root/gnu/machine
AgeCommit message (Expand)Author
2024-08-11gnu: Replace (almost) all uses of /run/setuid-programs....Tobias Geerinckx-Rice
2024-06-04file-systems: Add support for mounting CIFS file systems...Richard Sent
2024-02-19machine/ssh: Refresh parameterization of %CURRENT-SYSTEM....Ricardo Wurmus
2023-08-08system: Do not check initrd modules for pseudo file systems....Ludovic Courtès
2022-11-17machine: ssh: Validate 'system' field....Ludovic Courtès
2022-11-09machine/digital-ocean: Pull operating system definition out of string....Ricardo Wurmus
2022-11-09machine/digital-ocean: Set load path to Guile 3.0 directories....Ricardo Wurmus
2022-11-09machine/digital-ocean: Use static-networking-service-type....Ricardo Wurmus
2022-11-09machine/digital-ocean: Use nightly Guix....Ricardo Wurmus