Fix MIPS assembly code to work with newer GCC, where the "=h" constraint is no longer supported. --- libmad/fixed.h.orig 2004-02-16 21:02:03.000000000 -0500 +++ libmad/fixed.h 2011-10-29 18:47:21.000000000 -0400 @@ -304,8 +304,8 @@ * significant bit depends on OPT_ACCURACY via mad_f_scale64(). */ # define MAD_F_MLX(hi, lo, x, y) \ - asm ("mult %2,%3" \ - : "=l" (lo), "=h" (hi) \ + asm ("mult %2,%3\n\tmfhi %1" \ + : "=l" (lo), "=r" (hi) \ : "%r" (x), "r" (y)) # if defined(HAVE_MADD_ASM) >index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/bootloader.scm
AgeCommit message (Expand)Author
2019-03-24bootloader: Add a 'keyboard-layout' field....Ludovic Courtès
2019-03-24bootloader: Reindent record type definition....Ludovic Courtès
2019-03-24bootloader: Remove unused 'additional-configuration' field....Ludovic Courtès
2019-01-16bootloader: Remove deprecated 'device' field....Ludovic Courtès
2018-04-08discovery: Remove dependency on (guix ui)....Ludovic Courtès
2017-08-28bootloader: Emit warnings with 'warning'....Ludovic Courtès
2017-08-23gnu: bootloader: Deprecate "device" field in favor of "target"....Andy Wingo
2017-07-28bootloader: Use <menu-entry> for the bootloader side....Danny Milosavljevic
2017-06-08bootloader: Use menu-entry to define custom bootloader entries....Mathieu Othacehe
2017-05-16bootloader: Add extlinux support....Mathieu Othacehe