Fix MIPS assembly code to work with newer GCC, where the "=h" constraint is no longer supported. --- libmad/fixed.h.orig 2004-02-16 21:02:03.000000000 -0500 +++ libmad/fixed.h 2011-10-29 18:47:21.000000000 -0400 @@ -304,8 +304,8 @@ * significant bit depends on OPT_ACCURACY via mad_f_scale64(). */ # define MAD_F_MLX(hi, lo, x, y) \ - asm ("mult %2,%3" \ - : "=l" (lo), "=h" (hi) \ + asm ("mult %2,%3\n\tmfhi %1" \ + : "=l" (lo), "=r" (hi) \ : "%r" (x), "r" (y)) # if defined(HAVE_MADD_ASM) a href='/'>index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/telephony.scm
AgeCommit message (Expand)Author
2023-05-25tests: Fix the Jami service system tests....Maxim Cournoyer
2023-05-06tests: Add missing module imports for marionette-evaluated code....Ludovic Courtès
2022-09-26tests: telephony: Add missing import to fix jami tests....Maxim Cournoyer
2022-09-24Revert "tests: telephony: Add extra packages to %jami-os for debugging."...Maxim Cournoyer
2022-09-23tests: jami-provisioning: Fix test derivation name....Maxim Cournoyer
2022-09-23tests: telephony: Add extra packages to %jami-os for debugging....Maxim Cournoyer
2022-08-01gnu: telephony: Add a Jami test for a partially defined jami-account....Maxim Cournoyer
2022-06-10services: jami: Modernize to adjust to Shepherd 0.9+ changes....Maxim Cournoyer
2022-01-13services: Adjust the jami service for the upgraded jami....Maxim Cournoyer
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-08-02Reinstate "services: Add a service for Jami."...Maxim Cournoyer
2021-08-02Revert "services: Add a service for Jami."...Maxim Cournoyer
2021-08-02services: Add a service for Jami....Maxim Cournoyer