Fix MIPS assembly code to work with newer GCC, where the "=h"
constraint is no longer supported.
--- libmad/fixed.h.orig 2004-02-16 21:02:03.000000000 -0500
+++ libmad/fixed.h 2011-10-29 18:47:21.000000000 -0400
@@ -304,8 +304,8 @@
* significant bit depends on OPT_ACCURACY via mad_f_scale64().
*/
# define MAD_F_MLX(hi, lo, x, y) \
- asm ("mult %2,%3" \
- : "=l" (lo), "=h" (hi) \
+ asm ("mult %2,%3\n\tmfhi %1" \
+ : "=l" (lo), "=r" (hi) \
: "%r" (x), "r" (y))
# if defined(HAVE_MADD_ASM)
href='/'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-02-05 | gnu: Rename 'samba/fixed' to 'samba/pinned'....* gnu/packages/samba.scm: Rename variable 'samba/fixed' to 'samba/pinned' and
'samba/fixed-patched' to 'samba/fixed'.
* gnu/packages/gnome.scm (libsoup-minimal)[inputs]: Replace 'samba/fixed' with
'samba/pinned'.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
| Simon Tournier |
2023-01-17 | gnu: cifs-utils: Update to 7.0 [fixes CVE-2022-27239]....* gnu/packages/samba.scm (cifs-utils): Update to 7.0.
[arguments]: Use new style. Drop unneeded phase 'install-man-pages.
[inputs]: Drop labels.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Timotej Lazar |
2022-12-31 | gnu: samba/fixed: Replacement package has the same store name length....This is a follow-up to c39db91e51e55e46f177378c7b5a797441dc7d1b.
* gnu/packages/samba.scm (samba/fixed-patched)[version]: Set to 4.15.A.
| Marius Bakke |
2022-12-31 | gnu: samba/fixed: Update to 4.15.13....* gnu/packages/samba.scm (samba/fixed-patched): New variable.
(samba/fixed): Add replacement for samba/fixed-patched.
| Liliana Marie Prikler |
2022-12-31 | gnu: samba: Update to 4.16.8....* gnu/packages/samba.scm (samba): Update to 4.16.8.
| Liliana Marie Prikler |