Fix MIPS assembly code to work with newer GCC, where the "=h" constraint is no longer supported. --- libmad/fixed.h.orig 2004-02-16 21:02:03.000000000 -0500 +++ libmad/fixed.h 2011-10-29 18:47:21.000000000 -0400 @@ -304,8 +304,8 @@ * significant bit depends on OPT_ACCURACY via mad_f_scale64(). */ # define MAD_F_MLX(hi, lo, x, y) \ - asm ("mult %2,%3" \ - : "=l" (lo), "=h" (hi) \ + asm ("mult %2,%3\n\tmfhi %1" \ + : "=l" (lo), "=r" (hi) \ : "%r" (x), "r" (y)) # if defined(HAVE_MADD_ASM) a> : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/pack.scm
AgeCommit message (Expand)Author
2023-07-18tests: pack: Fix indentation....Maxim Cournoyer
2023-07-18pack: Move common build code to (guix build pack)....Maxim Cournoyer
2023-03-17Revert "tests: pack: Fix indentation."...Maxim Cournoyer
2023-02-27pack: Make sure tests can run without a world rebuild....Ludovic Courtès
2023-02-19pack: Add RPM format....Maxim Cournoyer
2023-02-19tests: pack: Fix indentation....Maxim Cournoyer
2022-10-22Remove now unnecessary uses of (guix grafts)....Ludovic Courtès