Fix MIPS assembly code to work with newer GCC, where the "=h" constraint is no longer supported. --- libmad/fixed.h.orig 2004-02-16 21:02:03.000000000 -0500 +++ libmad/fixed.h 2011-10-29 18:47:21.000000000 -0400 @@ -304,8 +304,8 @@ * significant bit depends on OPT_ACCURACY via mad_f_scale64(). */ # define MAD_F_MLX(hi, lo, x, y) \ - asm ("mult %2,%3" \ - : "=l" (lo), "=h" (hi) \ + asm ("mult %2,%3\n\tmfhi %1" \ + : "=l" (lo), "=r" (hi) \ : "%r" (x), "r" (y)) # if defined(HAVE_MADD_ASM) ef='/'>index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/build-utils.scm
AgeCommit message (Expand)Author
2020-11-16Properly deal with build directories containing '~'....Ludovic Courtès
2019-11-26tests: Avoid unnecessary use of 'mock'....Ludovic Courtès
2019-11-26tests: Avoid (catch 'srfi-34 …) form....Ludovic Courtès
2019-06-17utils: Add 'invoke/quiet'....Ludovic Courtès
2019-03-23Merge branch 'staging' into core-updatesMarius Bakke
2019-03-16booloader: Add 'invoke/quiet'....Ludovic Courtès
2019-03-16tests: Add 'with-environment-variable'....Ludovic Courtès
2019-02-08guix: Add wrap-script....Ricardo Wurmus
2016-09-07utils: 'wrap-program' produces only one wrapper file....Ludovic Courtès
2016-09-02tests: Test 'wrap-program' without building a package....Ludovic Courtès