Fix MIPS assembly code to work with newer GCC, where the "=h"
constraint is no longer supported.
--- libmad/fixed.h.orig 2004-02-16 21:02:03.000000000 -0500
+++ libmad/fixed.h 2011-10-29 18:47:21.000000000 -0400
@@ -304,8 +304,8 @@
* significant bit depends on OPT_ACCURACY via mad_f_scale64().
*/
# define MAD_F_MLX(hi, lo, x, y) \
- asm ("mult %2,%3" \
- : "=l" (lo), "=h" (hi) \
+ asm ("mult %2,%3\n\tmfhi %1" \
+ : "=l" (lo), "=r" (hi) \
: "%r" (x), "r" (y))
# if defined(HAVE_MADD_ASM)
/guix/'>guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-10-22 | gnu: patman: Apply patch for new Change-Id setting....* gnu/packages/bootloaders.scm (u-boot) [source]: Apply patch.
* gnu/packages/patches/u-boot-patman-change-id.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* .patman (keep_change_id): Use it.
Series-changes: 3
- New commit
Change-Id: I33c03013f6a260b5f5d80212b7b6ebe8a3f97efa
| Maxim Cournoyer |
2023-05-01 | .patman: Remove get_maintainer_script option....This is now handled at the level of git via its new '--header-cmd' option,
which produces X-Debbugs-CC headers.
* .patman (get_maintainer_script): Delete option.
| Maxim Cournoyer |
2023-02-25 | .patman: Ignore bad tags....The feature is not used in Guix, and it produces extraneous warnings.
* .patman (ignore_bad_tags): Set option to True.
| Maxim Cournoyer |
2022-12-28 | .patman: New configuration file....* .patman: New file.
Series-to: 60218@debbugs.gnu.org
Series-cc: rekado@elephly.net, othacehe@gnu.org
Series-version: 2
| Maxim Cournoyer |