Fix MIPS assembly code to work with newer GCC, where the "=h"
constraint is no longer supported.
--- libmad/fixed.h.orig 2004-02-16 21:02:03.000000000 -0500
+++ libmad/fixed.h 2011-10-29 18:47:21.000000000 -0400
@@ -304,8 +304,8 @@
* significant bit depends on OPT_ACCURACY via mad_f_scale64().
*/
# define MAD_F_MLX(hi, lo, x, y) \
- asm ("mult %2,%3" \
- : "=l" (lo), "=h" (hi) \
+ asm ("mult %2,%3\n\tmfhi %1" \
+ : "=l" (lo), "=r" (hi) \
: "%r" (x), "r" (y))
# if defined(HAVE_MADD_ASM)
ef='/'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-01-22 | gnu: sssd: Undefine SMB_HAS_NEW_NDR_PULL_STEAL_SWITCH....This commit follows a7fb50b577760e8409f40c7038a7c9a53ba98db6.
* gnu/packages/sssd.scm [arguments]: Undefine
SMB_HAS_NEW_NDR_PULL_STEAL_SWITCH in add-config-in phase.
Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
| Remco van 't Veer |
2022-01-22 | gnu: sssd: Fix build with samba-4.15.3....* gnu/packages/patches/sssd-fix-samba-4.15.3.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add this.
* gnu/packages/sssd.scm [source]: Add this.
[native-inputs]: Add AUTOCONF.
[arguments]: Add add-config-in phase.
Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
| Remco van 't Veer |
2021-12-18 | gnu: sssd: Fix build with glibc-2.33...* gnu/packages/patches/sssd-collision-with-external-nss-symbol.patch: Commit from sssd repo
* gnu/packages/sssd.scm: Add patch
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Remco van 't Veer |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2021-10-07 | gnu: Add adcli....* gnu/packages/sssd.scm (adcli): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Timotej Lazar |