Copied from Debian. From: Dave Martin Subject: "rsc" doesnt exist anymore in thumb2 diff --git a/fixed.h b/fixed.h index 4b58abf..ba4bc26 100644 --- a/fixed.h +++ b/fixed.h @@ -275,12 +275,25 @@ mad_fixed_t mad_f_mul_inline(mad_fixed_t x, mad_fixed_t y) : "+r" (lo), "+r" (hi) \ : "%r" (x), "r" (y)) +#ifdef __thumb__ +/* In Thumb-2, the RSB-immediate instruction is only allowed with a zero + operand. If needed this code can also support Thumb-1 + (simply append "s" to the end of the second two instructions). */ +# define MAD_F_MLN(hi, lo) \ + asm ("rsbs %0, %0, #0\n\t" \ + "sbc %1, %1, %1\n\t" \ + "sub %1, %1, %2" \ + : "+&r" (lo), "=&r" (hi) \ + : "r" (hi) \ + : "cc") +#else /* ! __thumb__ */ # define MAD_F_MLN(hi, lo) \ asm ("rsbs %0, %2, #0\n\t" \ "rsc %1, %3, #0" \ - : "=r" (lo), "=r" (hi) \ + : "=&r" (lo), "=r" (hi) \ : "0" (lo), "1" (hi) \ : "cc") +#endif /* __thumb__ */ # define mad_f_scale64(hi, lo) \ ({ mad_fixed_t __result; \ aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
AgeCommit message (Expand)Author
2019-01-15gnu: yosys: Update to 0.8....Danny Milosavljevic
2019-01-15gnu: arachne-pnr: Fix tests....Danny Milosavljevic
2019-01-15gnu: icestorm: Update to 0.0-2-c0cbae88a....Danny Milosavljevic
2019-01-15gnu: arachne-pnr: Update to 840bdfdeb....Amin Bandali
2018-10-30gnu: yosys: Don't use unstable tarball....Tobias Geerinckx-Rice
2018-07-05gnu: gtkwave: Mark up description....Tobias Geerinckx-Rice
2018-07-04gnu: gtkwave: Update to 3.3.91....Tobias Geerinckx-Rice
2018-06-26gnu: yosys: Return #t from all phases....Tobias Geerinckx-Rice
2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver
2018-02-19gnu: iverilog: Use Texinfo in description....Tobias Geerinckx-Rice
2018-02-19gnu: iverilog: Update to 10.2....Tobias Geerinckx-Rice
2017-10-03Update e-mail for Theodoros Foradis....Theodoros Foradis
2017-07-29gnu: yosys: Add dependency on z3....Theodoros Foradis
2017-06-20gnu: Move contents of zip module into compression module....Arun Isaac