Copied from Debian. From: Dave Martin Subject: "rsc" doesnt exist anymore in thumb2 diff --git a/fixed.h b/fixed.h index 4b58abf..ba4bc26 100644 --- a/fixed.h +++ b/fixed.h @@ -275,12 +275,25 @@ mad_fixed_t mad_f_mul_inline(mad_fixed_t x, mad_fixed_t y) : "+r" (lo), "+r" (hi) \ : "%r" (x), "r" (y)) +#ifdef __thumb__ +/* In Thumb-2, the RSB-immediate instruction is only allowed with a zero + operand. If needed this code can also support Thumb-1 + (simply append "s" to the end of the second two instructions). */ +# define MAD_F_MLN(hi, lo) \ + asm ("rsbs %0, %0, #0\n\t" \ + "sbc %1, %1, %1\n\t" \ + "sub %1, %1, %2" \ + : "+&r" (lo), "=&r" (hi) \ + : "r" (hi) \ + : "cc") +#else /* ! __thumb__ */ # define MAD_F_MLN(hi, lo) \ asm ("rsbs %0, %2, #0\n\t" \ "rsc %1, %3, #0" \ - : "=r" (lo), "=r" (hi) \ + : "=&r" (lo), "=r" (hi) \ : "0" (lo), "1" (hi) \ : "cc") +#endif /* __thumb__ */ # define mad_f_scale64(hi, lo) \ ({ mad_fixed_t __result; \ href='/guix/about/'>aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
AgeCommit message (Expand)Author
2020-01-22gnu: Replace uses of 'libjpeg' with 'libjpeg-turbo'....Marius Bakke
2019-12-19gnu: tcl: Fix cross-compilation....Mathieu Othacehe
2019-12-05gnu: Tcl/Tk: Update to 8.6.10....Marius Bakke
2019-10-14Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe
2019-10-13gnu: tcl: Update home page....Marius Bakke
2019-09-24gnu: tk: Fix cross-compilation....Mathieu Othacehe
2019-09-24gnu: tcl: Fix cross-compilation....Mathieu Othacehe
2019-06-27Merge branch 'master' into core-updatesLudovic Courtès
2019-06-22gnu: Add go-github.com-nsf-gothic....Julien Lepiller
2019-06-22gnu: Use license: prefix in tcl.scm....Julien Lepiller
2019-03-01Merge branch 'staging' into core-updatesMarius Bakke
2019-02-25gnu: tcllib: Update to 1.19....Tobias Geerinckx-Rice
2019-02-25gnu: tcllib: Don't use NAME in source URI....Tobias Geerinckx-Rice