Copied from Debian.
From: Dave Martin
Subject: "rsc" doesnt exist anymore in thumb2
diff --git a/fixed.h b/fixed.h
index 4b58abf..ba4bc26 100644
--- a/fixed.h
+++ b/fixed.h
@@ -275,12 +275,25 @@ mad_fixed_t mad_f_mul_inline(mad_fixed_t x, mad_fixed_t y)
: "+r" (lo), "+r" (hi) \
: "%r" (x), "r" (y))
+#ifdef __thumb__
+/* In Thumb-2, the RSB-immediate instruction is only allowed with a zero
+ operand. If needed this code can also support Thumb-1
+ (simply append "s" to the end of the second two instructions). */
+# define MAD_F_MLN(hi, lo) \
+ asm ("rsbs %0, %0, #0\n\t" \
+ "sbc %1, %1, %1\n\t" \
+ "sub %1, %1, %2" \
+ : "+&r" (lo), "=&r" (hi) \
+ : "r" (hi) \
+ : "cc")
+#else /* ! __thumb__ */
# define MAD_F_MLN(hi, lo) \
asm ("rsbs %0, %2, #0\n\t" \
"rsc %1, %3, #0" \
- : "=r" (lo), "=r" (hi) \
+ : "=&r" (lo), "=r" (hi) \
: "0" (lo), "1" (hi) \
: "cc")
+#endif /* __thumb__ */
# define mad_f_scale64(hi, lo) \
({ mad_fixed_t __result; \
>
aboutsummaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-04-23 | gnu: Add cppdap....* gnu/packages/debug.scm (cppdap): New variable.
* gnu/packages/patches/cppdap-add-CPPDAP_USE_EXTERNAL_GTEST_PACKAGE.patch: New
patch.
* gnu/local.mk (dist_patch_DATA): Register it.
Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Change-Id: I328ca0c01787defcc9d18f4ccd7762c86412cca7
Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
| Daniel Ziltener |
2024-01-25 | gnu: Add aflplusplus....* gnu/packages/debug.scm (aflplusplus): New variable.
Change-Id: Ibda36187e839d5f533d461444db25a7ba5567f0f
Modified-by: Hilton Chain <hako@ultrarare.space>
Signed-off-by: Hilton Chain <hako@ultrarare.space>
| Denis 'GNUtoo' Carikli |
2023-12-23 | gnu: rr: Update to 5.7.0....* gnu/packages/debug.scm (rr): Update to 5.7.0.
Change-Id: I5b70f5d266876077b533182ccdcd2160fec6fcc4
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Greg Hogan |
2023-09-15 | gnu: delve: Update to 1.21.0....* gnu/packages/debug.scm (delve): Update to 1.21.0.
[propagated-inputs]: Remove go.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| Andrew Jose |