Libgit2 1.8.0 went for 'git_commit *const' but 1.8.4 reverted back to
'const git_commit *'.
--- a/src/jamidht/conversationrepository.cpp
+++ b/src/jamidht/conversationrepository.cpp
@@ -783,7 +783,7 @@ ConversationRepository::Impl::createMergeCommit(git_index* index, const std::str
// Commit
git_buf to_sign = {};
// Check if the libgit2 library version is 1.8.0 or higher
-#if( LIBGIT2_VER_MAJOR > 1 ) || ( LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR >= 8 )
+#if( LIBGIT2_VER_MAJOR > 1 ) || ( LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR >= 8 && LIBGIT2_VER_REVISION <= 3)
// For libgit2 version 1.8.0 and above
git_commit* const parents_ptr[2] {parents[0].get(), parents[1].get()};
#else
@@ -1870,7 +1870,7 @@ ConversationRepository::Impl::commit(const std::string& msg, bool verifyDevice)
git_buf to_sign = {};
// Check if the libgit2 library version is 1.8.0 or higher
-#if( LIBGIT2_VER_MAJOR > 1 ) || ( LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR >= 8 )
+#if( LIBGIT2_VER_MAJOR > 1 ) || ( LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR >= 8 && LIBGIT2_VER_REVISION <= 3)
// For libgit2 version 1.8.0 and above
git_commit* const head_ref[1] = {head_commit.get()};
#else
4dfb83bedfeca4640fa'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2022-07-12 | guix: Really export 'define-public'....This is a followup to 3858275962f1ac567b5dce2355035f9eddea0a05, which
didn't have any effect.
* guix.scm: Explicitly use (guix packages) so #:re-export-and-replace
is effective.
| Ludovic Courtès |
2021-09-14 | guix: Replace 'define-public'....This is a followup to 8531997d2a1e10d574a6e9ab70bc86ade6af4733.
* guix.scm: Use #:re-export-and-replace for 'define-public'.
| Ludovic Courtès |
2021-06-29 | (guix) no longer pulls in (guix ftp-client)....That choice was made in 2014 and never made much sense.
* guix.scm (%public-modules): Remove 'ftp-client'.
| Ludovic Courtès |