The Clar test framework has a bug whereby it skips the parsing phase on files with mtime=0. Reported upstream at . diff --git a/tests/generate.py b/tests/generate.py index b639c8f..111ca41 100644 --- a/tests/generate.py +++ b/tests/generate.py @@ -63,3 +63,3 @@ class Module(object): - self.mtime = 0 + self.mtime = None # Guix sets all file mtimes to '0' self.enabled = True .org/cgit-static/cgit.png' alt='cgit logo'/> index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/gremlin.scm
AgeCommit message (Expand)Author
2022-01-16tests: Fix file-needed/recursive on aarch64-linux....Fixes: <https://issues.guix.gnu.org/52943>. * tests/gremlin.scm (file-needed/recursive)[ground-truth]: On aarch64-linux, remove the dynamic linker from this list. Pierre Langlois
2022-01-14gremlin: Adjust tests for i686 and beyond....Fixes <https://issues.guix.gnu.org/52752>. Reported by Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>. * tests/gremlin.scm ("file-needed/recursive"): Augment the list of vDSO names. Ludovic Courtès
2022-01-08tests: Fix file-needed/recursive on powerpc64le-linux....Fixes: <https://issues.guix.gnu.org/52940>. * tests/gremlin.scm (file-needed/recursive): Consider two entries to be equivalent not when they are the same string, but rather when they refer to the same file. [ground-truth]: In addition to strings that begin with "linux-vdso.so", remove strings that begin with "linux-vdso64.so". Chris Marusich
2021-06-23tests: gremlin: Skip file-needed/recursive if DT_NEEDED is empty....* tests/gremlin.scm (file-needed/recursive): Skip the test when (file-runpath %guile-executable) evaluates to the empty list. This causes the test to be correctly skipped in the case where Guix has been built using a foreign distro's toolchain and libraries. Chris Marusich
2021-04-22gremlin: 'elf-dynamic-info' returns a file name rathern than a dynamic entry....* guix/build/gremlin.scm (elf-dynamic-info): Return the dynamic entry value, not the dynamic entry. * tests/gremlin.scm ("elf-dynamic-info-soname"): New test. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Dion Mendel
2020-12-01gremlin: Add 'file-needed/recursive'....* guix/build/gremlin.scm (file-needed/recursive): New procedure. * tests/gremlin.scm ("file-needed/recursive"): New test. Ludovic Courtès
2020-09-19gremlin: Add 'set-file-runpath', 'file-runpath', and 'file-needed'....* guix/build/gremlin.scm (file-dynamic-info, file-runpath, file-needed): New procedures. (&missing-runpath-error, &runpath-too-long-error): New condition types. (set-file-runpath): New procedure. * tests/gremlin.scm ("set-file-runpath + file-runpath"): New test. Ludovic Courtès
2019-05-18gremlin: Adjust tests for foreign distros....Fixes <https://bugs.gnu.org/35775>. * tests/gremlin.scm ("elf-dynamic-info-needed, executable"): Expect only libguile and libc among NEEDED. ("strip-runpath"): Pass '--enable-new-dtags' to get RUNPATH, not RPATH. Ting-Wei Lan
2018-08-25Merge branch 'staging' into core-updatesMarius Bakke
2018-08-21gremlin: 'elf-dynamic-info-needed' test is no longer skipped....* tests/gremlin.scm (%guile-executable): Use /proc/self/exe instead of (command-line). For a while now, the first element of (command-line) was "./build-aux/test-driver.scm"; consequently the test was always skipped. Ludovic Courtès