*/
#include "test-cnc-utils.h"
#define PROVIDER_NAME "PostgreSQL"
+#define PROVIDER_DB_CREATE_PARAMS "POSTGRESQL_DBCREATE_PARAMS"
+#define PROVIDER_CNC_PARAMS "POSTGRESQL_CNC_PARAMS"
#define GDA_PGSQL_ERROR_HANDLE(e) (g_print("Error: %s: %s\n", G_STRLOC, e && e->message ? e->message : "No default"));
@@ -1335,6 +1338,19 @@ main(gint argc, gchar *argv[])
{
setlocale (LC_ALL,"");
+ const gchar *db_create_str;
+ const gchar *cnc_params;
+
+ db_create_str = g_getenv (PROVIDER_DB_CREATE_PARAMS);
+ cnc_params = g_getenv (PROVIDER_CNC_PARAMS);
+
+ if (!db_create_str || !cnc_params) {
+ g_print ("Please set POSTGRESQL_DBCREATE_PARAMS and POSTGRESQL_CNC_PARAMS variable"
+ "with dbname, host, user and port (usually 5432)\n");
+ g_print ("Test will not be performed\n");
+ return EXIT_SUCCESS;
+ }
+
g_test_init (&argc,&argv,NULL);
g_test_add ("/test-server-operation-sqlite/old-so-module",
--
GitLab
e to 2023.09.4.
[arguments]: Skip testConrec test in check phase.
[native-inputs]: Replace catch2 with catch2-3.
* gnu/packages/patches/rdkit-unbundle-external-dependencies.patch: Adjust
patch.
[supported-systems]: New field.
Signed-off-by: Christopher Baines <mail@cbaines.net>
David Elsing |
2024-02-13 | gnu: freesasa: Fix memerr tests....* gnu/packages/chemistry.scm (freesasa)[arguments]: Add
"CFLAGS=-fno-builtin-malloc" to #:configure-flags.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| David Elsing |
2024-02-13 | gnu: avalon-toolkit: Update to 2.0.5a....The bug freeing static memory and the makefile have been improved upstream, so
we don't have to work around them anymore. Now, two static libraries are built
instead.
* gnu/packages/chemistry.scm (avalon-toolkit): Update to 2.0.5a.
[source]: Switch to git reference from GitHub. Adjust snippet. Add patch from
the RDKit fork.
[arguments]: Remove 'dont-free-static-memory phase. Use provided
makefile. Adjust 'install phase.
* gnu/packages/patches/avalon-toolkit-rdkit-fixes.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| David Elsing |
2024-02-13 | gnu: yaehmop: Update to 2023.03.1....* gnu/packages/chemistry.scm (yaehmop): Update to 2023.03.1.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| David Elsing |
2024-02-13 | gnu: coordgenlibs: Update to 3.0.2....* gnu/packages/chemistry.scm (coordgenlibs): Update to 3.0.2.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| David Elsing |
2024-02-13 | gnu: maeparser: Update to 1.3.1....* gnu/packages/chemistry.scm (maeparser): Update to 1.3.1.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| David Elsing |
2024-02-13 | gnu: gemmi: Update to 0.6.4....* gnu/packages/chemistry.scm (gemmi): Update to 0.6.4.
[arguments]: Adjust include/gemmi/sprintf.hpp -> src/sprintf.cpp.
(freesasa)[arguments]: Link to gemmi_cpp explicitly.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| David Elsing |
2024-01-09 | gnu: msgpack: Deprecate with msgpack-c....* gnu/packages/serialization.scm (msgpack-c): New variable.
(msgpack-cxx): New variable.
(msgpack): Rename to...
(msgpack-3): ... this, and inherit from msgpack-c.
* gnu/packages/vim.scm (eovim) [arguments]: Add help-cmake-find-msgpack-c
phase.
[inputs]: Replace msgpack with msgpack-c.
* gnu/packages/terminals.scm (tmate)
[inputs]: Replace msgpack with msgpack-3.
* gnu/packages/networking.scm (opendht)
[propagated-inputs]: Replace msgpack with msgpack-cxx.
* gnu/packages/chemistry.scm (mmtf-cpp) [propagated-inputs]: Likewise.
| Maxim Cournoyer |