From bebdffb4de586fb43fd07ac549121f4b22f6812d Mon Sep 17 00:00:00 2001 From: "Douglas R. Reno" Date: Mon, 18 Oct 2021 13:18:01 -0500 Subject: [PATCH] Fix CVE-2021-39359 by forcing TLS certificate validation This was done by adding "ssl-use-system-ca-file", TRUE to the options for each soup_session_new_with_options() call that was made. Tested on Linux From Scratch 11.0 and Debian 11. Fixes #249 --- providers/web/gda-web-provider.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/providers/web/gda-web-provider.c b/providers/web/gda-web-provider.c index cf8d14dc3..cc818895f 100644 --- a/providers/web/gda-web-provider.c +++ b/providers/web/gda-web-provider.c @@ -355,8 +355,8 @@ gda_web_provider_open_connection (GdaServerProvider *provider, GdaConnection *cn g_rec_mutex_init (& (cdata->mutex)); cdata->server_id = NULL; cdata->forced_closing = FALSE; - cdata->worker_session = soup_session_new (); - cdata->front_session = soup_session_new_with_options ("max-conns-per-host", 1, NULL); + cdata->worker_session = soup_session_new_with_options ("ssl-use-system-ca-file", TRUE, NULL); + cdata->front_session = soup_session_new_with_options ("max-conns-per-host", 1, "ssl-use-system-ca-file", TRUE, NULL); if (use_ssl) { server_url = g_string_new ("https://"); g_print ("USING SSL\n"); -- GitLab 00e7e88b67f53aefc956e238eea5d65ca1bfa6'>commitdiff
path: root/gnu/packages/spice.scm
AgeCommit message (Expand)Author
2023-04-09gnu: libcacard: Use latest meson....Maxim Cournoyer
2023-04-03gnu: libcacard: Build with older meson....Efraim Flashner
2023-02-25gnu: virglrenderer: Update to 0.10.4....Simon Streit
2023-02-25gnu: spice-gtk: Adjust the default file name of the ACL helper binary....Maxim Cournoyer
2023-02-25gnu: spice-gtk: Enable support for polkit, webdav and others....Maxim Cournoyer
2023-02-25gnu: spice-vdagent: Update to 0.22.1....Maxim Cournoyer
2023-02-25gnu: spice: Update to 0.15.1....Maxim Cournoyer
2023-02-25gnu: libcacard: Remove obsolete configure flags....Maxim Cournoyer
2023-02-25gnu: virglrenderer: Update to 0.7.0....Maxim Cournoyer
2023-02-25gnu: usbredir: Update to 0.13.0....Maxim Cournoyer
2023-02-25gnu: spice-protocol: Update to 0.14.4....Maxim Cournoyer
2023-02-25gnu: spice-gtk: Propagate libjpeg-turbo, lz4, opus, and usbredir....Maxim Cournoyer
2023-02-25gnu: spice-gtk: Update to 0.42....Maxim Cournoyer
2023-02-25gnu: spice-gtk: Use gexps....Maxim Cournoyer
2023-02-25gnu: spice-gtk: Remove input labels....Maxim Cournoyer
2023-02-25gnu: spice-gtk: Fix indentation and normalize field order....Maxim Cournoyer