commit cdb28383402d248dbc6062f4391b038375c52385 Author: Fabrice Fontaine Date: Fri Jul 17 21:25:03 2020 +0200 CMakeLists.txt: fix paths when FTDIPP is set Use the same project name (i.e. libftdi1 and not libftdipp1) when FTDIPP is enabled as suggested by Aurelien Jarno in http://developer.intra2net.com/mailarchive/html/libftdi/2020/msg00044.html Without this change, the libftdi1.pc config file defines the include path as /usr/local/include/libftdipp1 while the ftdi.h file is actually installed in /usr/local/include/libftdi1 This is an issue for example for libsigrok which will fail on: In file included from src/hardware/asix-sigma/protocol.c:27: src/hardware/asix-sigma/protocol.h:28:10: fatal error: ftdi.h: No such file or directory 28 | #include | ^~~~~~~~ Fixes: - http://autobuild.buildroot.org/results/1427f44e36752c337791597fab47a1889552a2fe Signed-off-by: Fabrice Fontaine diff --git a/CMakeLists.txt b/CMakeLists.txt index 5aecafc..3b0b87c 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -136,7 +136,7 @@ endif () add_subdirectory(src) if ( FTDIPP ) - project(libftdipp1 C CXX) + project(libftdi1 C CXX) add_subdirectory(ftdipp) endif () if ( PYTHON_BINDINGS ) diff
AgeCommit message (Expand)Author
2017-11-01tests: ssh: Make sure we can run executables from PATH....Marius Bakke
2017-07-23Merge branch 'master' into core-updatesLeo Famulari
2017-07-20tests: Use 'virtual-machine' records instead of monadic procedures....Ludovic Courtès
2017-07-18tests: ssh: Use 'guile-ssh'....Ludovic Courtès
2017-06-12marionette: Factorize 'wait-for-file'....Ludovic Courtès
2017-05-21tests: ssh: Use 'guile2.0-ssh'....Ludovic Courtès
2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès
2017-03-21tests: ssh: Add a test for SFTP....Clément Lassieur
2017-03-21tests: ssh: Abstract session connection and authentication....Clément Lassieur
2016-10-03tests: ssh: Add Dropbear test....Ludovic Courtès
2016-10-03tests: ssh: Generalize....Ludovic Courtès
2016-10-03tests: Add 'openssh-service-type' test....Ludovic Courtès