# We insert a hook called "@SOUND_THEME_DIRECTORY@" where, at build time, we
# insert the directory of the package "sound-theme-freedesktop" in the store.
--- src/sound-theme-spec.c.orig 2015-01-11 13:13:29.520527358 +0100
+++ src/sound-theme-spec.c 2015-01-11 14:27:23.035046849 +0100
@@ -321,9 +321,13 @@
const char *g;
if (!(g = getenv("XDG_DATA_DIRS")) || *g == 0)
- return "/usr/local/share:/usr/share";
-
- return g;
+ return "@SOUND_THEME_DIRECTORY@";
+ else {
+ const char *stp = ":@SOUND_THEME_DIRECTORY@";
+ size_t len = strlen(stp) + strlen(g) + 1;
+ char *g2 = (char*) malloc(len);
+ return strcat(strcpy(g2, g), stp);
+ }
}
static int load_theme_dir(ca_theme_data *t, const char *name) {
witch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-06-09 | git: 'commit-difference' really excludes the ancestors of #:excluded....* guix/git.scm (commit-difference): Initialize VISITED to the closure of
OLD and EXCLUDED, as written in the docstring.
* tests/git.scm ("commit-difference, excluded commits"): Adjust
accordingly.
| Ludovic Courtès |
2020-05-25 | git: Add 'commit-relation'....* guix/git.scm (commit-relation): New procedure.
* tests/git.scm ("commit-relation"): New test.
| Ludovic Courtès |
2019-12-27 | git: 'commit-difference' takes a list of excluded commits....* guix/git.scm (commit-closure): Add 'visited' optional parameter.
(commit-difference): Add 'excluded' optional parameter; pass second
argument to 'commit-closure'.
* tests/git.scm ("commit-difference, excluded commits"): New test.
| Ludovic Courtès |
2019-09-23 | git: Add 'commit-difference'....* guix/git.scm (commit-closure, commit-difference): New procedures.
* guix/tests/git.scm, tests/git.scm: New files.
* Makefile.am (dist_noinst_DATA): Add guix/tests/git.scm.
(SCM_TESTS): Add tests/git.scm.
| Ludovic Courtès |