# We insert a hook called "@SOUND_THEME_DIRECTORY@" where, at build time, we # insert the directory of the package "sound-theme-freedesktop" in the store. --- src/sound-theme-spec.c.orig 2015-01-11 13:13:29.520527358 +0100 +++ src/sound-theme-spec.c 2015-01-11 14:27:23.035046849 +0100 @@ -321,9 +321,13 @@ const char *g; if (!(g = getenv("XDG_DATA_DIRS")) || *g == 0) - return "/usr/local/share:/usr/share"; - - return g; + return "@SOUND_THEME_DIRECTORY@"; + else { + const char *stp = ":@SOUND_THEME_DIRECTORY@"; + size_t len = strlen(stp) + strlen(g) + 1; + char *g2 = (char*) malloc(len); + return strcat(strcpy(g2, g), stp); + } } static int load_theme_dir(ca_theme_data *t, const char *name) { bmit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
AgeCommit message (Expand)Author
2018-11-29gnu: libabigail: Update to 1.5....Marius Bakke
2018-09-10gnu: Add libabigail....Marius Bakke
2018-08-01gnu: elfutils: Update to 0.173....Marius Bakke
2018-06-19gnu: elfutils: Update to 0.172....Vagrant Cascadian
2018-06-04gnu: elfutils: Disable test suite on MIPS....Mark H Weaver
2018-04-11Merge branch 'master' into core-updatesMark H Weaver
2018-04-11gnu: elfutils: Disable failing test....Efraim Flashner
2018-03-23gnu: libelf: Use invoke....Mark H Weaver
2018-03-20Revert "Revert "gnu: patchelf: Update argument phase.""...Marius Bakke
2018-03-20Revert "gnu: patchelf: Update argument phase."...Marius Bakke
2018-03-19patchelf: Use 'https' for source uri....Efraim Flashner
2018-03-19gnu: patchelf: Update argument phase....Efraim Flashner
2018-03-19gnu: patchelf: Use 'target-arm32?' for armhf-linux case....Efraim Flashner
2018-02-20gnu: nix, patchelf: Use HTTPS for nixos.org home pages....Tobias Geerinckx-Rice
2018-01-26gnu: elfutils: Mark up description....Tobias Geerinckx-Rice
2018-01-26gnu: elfutils: Update to 0.170....Tobias Geerinckx-Rice