# We insert a hook called "@SOUND_THEME_DIRECTORY@" where, at build time, we # insert the directory of the package "sound-theme-freedesktop" in the store. --- src/sound-theme-spec.c.orig 2015-01-11 13:13:29.520527358 +0100 +++ src/sound-theme-spec.c 2015-01-11 14:27:23.035046849 +0100 @@ -321,9 +321,13 @@ const char *g; if (!(g = getenv("XDG_DATA_DIRS")) || *g == 0) - return "/usr/local/share:/usr/share"; - - return g; + return "@SOUND_THEME_DIRECTORY@"; + else { + const char *stp = ":@SOUND_THEME_DIRECTORY@"; + size_t len = strlen(stp) + strlen(g) + 1; + char *g2 = (char*) malloc(len); + return strcat(strcpy(g2, g), stp); + } } static int load_theme_dir(ca_theme_data *t, const char *name) { 'switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/.dir-locals.el
AgeCommit message (Expand)Author
2024-04-03store: database: Remove with-statement and associated code....Christopher Baines
2024-04-03store: database: Remove call-with-savepoint and associated code....Christopher Baines
2023-10-20.dir-locals.el: Adjust indentation rule for ‘test-assertm’....Ludovic Courtès
2023-09-17.dir-locals.el: Update bug-reference configuration and document it....Maxim Cournoyer
2023-09-06.dir-locals: Streamline Geiser configuration....Maxim Cournoyer
2023-06-04records: Add MATCH-RECORD-LAMBDA....(unmatched-parenthesis ew syntax
2023-06-04dir-locals: Fix MATCH-RECORD indentation....(unmatched-parenthesis d
2023-03-17Revert gexp->derivation and computed-file indentation rules....Maxim Cournoyer
2023-03-05.dir-locals.el: Allow Guix root-dir overrides when working via Tramp....Brian Cully
2023-02-19.dir-locals: Add let-keywords indentation rules....Maxim Cournoyer
2023-02-02.dir-locals.el: Adjust indentation rule for test-assertm....Maxim Cournoyer
2023-02-02.dir-locals.el: Add indentation rule for computed-file....Maxim Cournoyer
2022-09-07.dir-locals.el: Update yas snippets directory....Andrew Tropin
2022-09-05.dir-locals.el: Add .go to completion-ignored-extensions....Andrew Tropin
2022-09-05.dir-locals.el: Add guix yasnippets....Andrew Tropin
2022-07-10monads: Add 'mparameterize'....Ludovic Courtès
2022-07-10.dir-locals.el: Restore Emacs 27 lisp-fill-paragraph behavior....Maxim Cournoyer
2022-06-28.dir-locals.el: Properly indent 'wrap-script'....Maxim Cournoyer