# We insert a hook called "@SOUND_THEME_DIRECTORY@" where, at build time, we
# insert the directory of the package "sound-theme-freedesktop" in the store.
--- src/sound-theme-spec.c.orig 2015-01-11 13:13:29.520527358 +0100
+++ src/sound-theme-spec.c 2015-01-11 14:27:23.035046849 +0100
@@ -321,9 +321,13 @@
const char *g;
if (!(g = getenv("XDG_DATA_DIRS")) || *g == 0)
- return "/usr/local/share:/usr/share";
-
- return g;
+ return "@SOUND_THEME_DIRECTORY@";
+ else {
+ const char *stp = ":@SOUND_THEME_DIRECTORY@";
+ size_t len = strlen(stp) + strlen(g) + 1;
+ char *g2 = (char*) malloc(len);
+ return strcat(strcpy(g2, g), stp);
+ }
}
static int load_theme_dir(ca_theme_data *t, const char *name) {
type='submit' value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-11-06 | nls: Update translations....* po/doc/guix-cookbook.es.po: New file.
* po/doc/local.mk: Add 'es' cookbook.
* doc/local.mk: Add 'es' cookbook.
| Julien Lepiller |
2021-10-17 | nls: Update translations. | Julien Lepiller |
2021-09-02 | nls: Update translations....* po/packages/it.po: New file.
* po/packages/LINGUAS: Add `it'.
* po/*/*.po: Update translations.
| Julien Lepiller |
2021-08-04 | nls: Update translations....* po/doc/guix-cookbook.ru.po: New file.
* po/doc/guix-cookbook.sk.po: New file.
* po/*/*.po: Update translations.
* doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk.
(info_TEXINFOS): Add Russian and Slovak cookbooks.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po
files.
| Julien Lepiller |
2021-05-11 | nls: Update translations. | Maxim Cournoyer |
2021-05-10 | nls: Update translations. | Maxim Cournoyer |
2021-04-18 | nls: Add Persian translation....* po/packages/fa.po: New file.
* po/packages/LINGUAS: Add 'fa'.
* po/doc/guix-cookbook.fa.po: New file.
* po/doc/guix-manual.fa.po: New file.
* po/doc/local.mk (DOC_PO_FILES, DOC_COOKBOOK_PO_FILES): Add them.
* doc/local.mk (info_TEXINFOS): Add them.
| Julien Lepiller |