This patch fixes the build of adb on linux. Copied from archlinux repository: https://git.archlinux.org/svntogit/community.git/tree/trunk/fix_build.patch?h=packages/android-tools diff --git a/adb/sysdeps.h b/adb/sysdeps.h index 75dcc86..867f3ec 100644 --- a/adb/sysdeps.h +++ b/adb/sysdeps.h @@ -25,6 +25,7 @@ #endif #include +#include #include #include @@ -831,7 +832,16 @@ static __inline__ int adb_is_absolute_host_path(const char* path) { static __inline__ unsigned long adb_thread_id() { - return (unsigned long)gettid(); + // TODO: this function should be merged with GetThreadId +#if defined(__BIONIC__) + return gettid(); +#elif defined(__APPLE__) + return syscall(SYS_thread_selfid); +#elif defined(__linux__) + return syscall(__NR_gettid); +#elif defined(_WIN32) + return GetCurrentThreadId(); +#endif } #endif /* !_WIN32 */ diff --git a/base/errors_unix.cpp b/base/errors_unix.cpp index 296995e..48269b6 100644 --- a/base/errors_unix.cpp +++ b/base/errors_unix.cpp @@ -17,6 +17,7 @@ #include "android-base/errors.h" #include +#include namespace android { namespace base { diff --git a/base/file.cpp b/base/file.cpp index da1adba..91a3901 100644 --- a/base/file.cpp +++ b/base/file.cpp @@ -20,6 +20,7 @@ #include #include #include +#include #include diff --git a/base/logging.cpp b/base/logging.cpp index 1741871..e97c7f1 100644 --- a/base/logging.cpp +++ b/base/logging.cpp @@ -21,6 +21,7 @@ #include "android-base/logging.h" #include +#include // For getprogname(3) or program_invocation_short_name. #if defined(__ANDROID__) || defined(__APPLE__) ue='range'>range
AgeCommit message (Expand)Author
2020-05-15mailmap: Update for self....Mathieu Othacehe
2020-05-13mailmap: Update entries for Nikita....nikita
2020-03-28Update email address and Savannah handle for Amin Bandali....Amin Bandali
2020-02-09Update e-mail address for Jakob L. Kreuze....Tobias Geerinckx-Rice
2020-01-17Update email address for Amin Bandali....Amin Bandali
2019-12-19Update email for Brett Gilio....Brett Gilio
2019-12-18gnu: leocad: Update to 19.07.1....Eric Bavier
2019-05-03Correct email address for ison....ison
2019-03-18Correct name and email address for ng0....ng0
2019-01-21Update .mailmap....Mathieu Othacehe
2018-08-27Update email for Pierre Neidhardt....Pierre Neidhardt
2018-07-16mailmap: Add a line for Pierre-Antoine....Ludovic Courtès
2018-07-16mailmap: Add another line for myself....Nils Gillmann
2018-03-20Correct name and Email for ng0....ng0
2018-02-11mailmap: Adjust entries for ng0....ng0
2017-11-26Update e-mail for ng0....ng0
2017-10-03Update e-mail for Theodoros Foradis....Theodoros Foradis
2017-08-29Update e-mail for Kei Kebreau....Kei Kebreau
2017-08-13mailmap: fix entries for ng0....ng0