This patch fixes the build of adb on linux. Copied from archlinux repository: https://git.archlinux.org/svntogit/community.git/tree/trunk/fix_build.patch?h=packages/android-tools diff --git a/adb/sysdeps.h b/adb/sysdeps.h index 75dcc86..867f3ec 100644 --- a/adb/sysdeps.h +++ b/adb/sysdeps.h @@ -25,6 +25,7 @@ #endif #include +#include #include #include @@ -831,7 +832,16 @@ static __inline__ int adb_is_absolute_host_path(const char* path) { static __inline__ unsigned long adb_thread_id() { - return (unsigned long)gettid(); + // TODO: this function should be merged with GetThreadId +#if defined(__BIONIC__) + return gettid(); +#elif defined(__APPLE__) + return syscall(SYS_thread_selfid); +#elif defined(__linux__) + return syscall(__NR_gettid); +#elif defined(_WIN32) + return GetCurrentThreadId(); +#endif } #endif /* !_WIN32 */ diff --git a/base/errors_unix.cpp b/base/errors_unix.cpp index 296995e..48269b6 100644 --- a/base/errors_unix.cpp +++ b/base/errors_unix.cpp @@ -17,6 +17,7 @@ #include "android-base/errors.h" #include +#include namespace android { namespace base { diff --git a/base/file.cpp b/base/file.cpp index da1adba..91a3901 100644 --- a/base/file.cpp +++ b/base/file.cpp @@ -20,6 +20,7 @@ #include #include #include +#include #include diff --git a/base/logging.cpp b/base/logging.cpp index 1741871..e97c7f1 100644 --- a/base/logging.cpp +++ b/base/logging.cpp @@ -21,6 +21,7 @@ #include "android-base/logging.h" #include +#include // For getprogname(3) or program_invocation_short_name. #if defined(__ANDROID__) || defined(__APPLE__) '>
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-26 12:25:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-26 12:34:11 +0100
commitfe9bdd7ef77f0b1219975e9bf5df3535b8c67a5c (patch)
tree98a10fc04bf8e579ffc962b5b684c8a404ef4239 /gnu/system/install.scm
parentb8ac0bf3b279dee85af7ff7ca7d4ec5fc0ade338 (diff)
downloadguix-fe9bdd7ef77f0b1219975e9bf5df3535b8c67a5c.tar.gz
guix-fe9bdd7ef77f0b1219975e9bf5df3535b8c67a5c.zip
gnu: r-gdtools: Update to 0.3.6.
* gnu/packages/statistics.scm (r-gdtools): Update to 0.3.6. Change-Id: I87b02d5665f60c80d28085895b2693cda94f95bc
Diffstat (limited to 'gnu/system/install.scm')
0 files changed, 0 insertions, 0 deletions