Remove code added by 'JiaT75', the malicious actor that backdoored `xz`: https://github.com/libarchive/libarchive/pull/2101 At libarchive, they are reviewing all code contributed by this actor: https://github.com/libarchive/libarchive/issues/2103 See the original disclosure and subsequent discussion for more information about this incident: https://seclists.org/oss-sec/2024/q1/268 Patch copied from upstream source repository: https://github.com/libarchive/libarchive/pull/2101/commits/e200fd8abfb4cf895a1cab4d89b67e6eefe83942 From 6110e9c82d8ba830c3440f36b990483ceaaea52c Mon Sep 17 00:00:00 2001 From: Ed Maste Date: Fri, 29 Mar 2024 18:02:06 -0400 Subject: [PATCH] tar: make error reporting more robust and use correct errno (#2101) As discussed in #1609. --- tar/read.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/tar/read.c b/tar/read.c index af3d3f42..a7f14a07 100644 --- a/tar/read.c +++ b/tar/read.c @@ -371,8 +371,9 @@ read_archive(struct bsdtar *bsdtar, char mode, struct archive *writer) if (r != ARCHIVE_OK) { if (!bsdtar->verbose) safe_fprintf(stderr, "%s", archive_entry_pathname(entry)); - fprintf(stderr, ": %s: ", archive_error_string(a)); - fprintf(stderr, "%s", strerror(errno)); + safe_fprintf(stderr, ": %s: %s", + archive_error_string(a), + strerror(archive_errno(a))); if (!bsdtar->verbose) fprintf(stderr, "\n"); bsdtar->return_value = 1; -- 2.41.0 iff
path: root/gnu/tests/networking.scm
AgeCommit message (Expand)Author
2023-11-05tests: inetd: Avoid race condition when looking for PID file....Ludovic Courtès
2023-10-11services: static-networking: Add support for bonding....Alexey Abramov
2023-05-14tests: dhcpd: Avoid race conditions....Ludovic Courtès
2023-05-11tests: openvswitch: Wait for 'openvswitch-configuration' to be up....Ludovic Courtès
2021-12-13tests: static-networking: Adjust to new style....Ludovic Courtès
2021-12-13Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-12-12tests: Replace uses of deprecated 'static-networking-service'....Ludovic Courtès
2021-12-12services: static-networking: Change interface to mimic netlink....Ludovic Courtès
2021-12-12tests: openvswitch: Check whether ovs0 is up....Ludovic Courtès
2021-12-12tests: Add 'static-networking' test....Ludovic Courtès
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-04-12gnu: tests: Test basic funtionality of the IPFS service....Maxime Devos
2020-07-11tests: networking: Use 'net.ifnames=0' for the Open vSwitch test....Marius Bakke
2020-04-10tests: openvswitch: Use the absolute file name of ovs-vsctl....Marius Bakke
2020-03-16tests: dhcpd: Adjust network interface name....Ludovic Courtès