This fix comes from an upstream pull request, see
https://pagure.io/libaio/pull-request/22#commit_list
diff --git a/harness/cases/23.t b/harness/cases/23.t
index cc5a8a1..9bbb05c 100644
--- a/harness/cases/23.t
+++ b/harness/cases/23.t
@@ -72,7 +72,7 @@ static void fail_errno(const char *format, ...)
static void *thrproc2(void *arg)
{
for (;;) {
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)
@@ -92,7 +92,7 @@ static void *thrproc3(void *arg)
{
for (;;) {
char c;
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)
guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-12-28 | gnu: enlightenment: Update to 0.25.0....* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.0.
[arguments]: Remove unneeded configure-flags. Don't remove phase which
isn't part of the build system. Remove trailing #t from phases.
[inputs]: Add libexif.
* gnu/packages/patches/enlightenment-fix-setuid-path.patch: Refresh patch.
| Efraim Flashner |