Use shared gtest instead of submodule diff --git a/CMakeLists.txt b/CMakeLists.txt index 617e4b2..2857875 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -18,7 +18,6 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/") include(GNUInstallDirs) project(leelaz) -add_subdirectory(gtest EXCLUDE_FROM_ALL) # We don't want to install gtest, exclude it from `all` # Required Packages set(Boost_MIN_VERSION "1.58.0") @@ -27,6 +26,7 @@ find_package(Boost 1.58.0 REQUIRED program_options filesystem) find_package(Threads REQUIRED) find_package(ZLIB REQUIRED) find_package(OpenCL REQUIRED) +find_package(GTest REQUIRED) # We need OpenBLAS for now, because we make some specific # calls. Ideally we'd use OpenBLAS is possible and fall back to # not doing those calls if it's not present. @@ -93,6 +93,7 @@ include_directories(${IncludePath}) include_directories(${Boost_INCLUDE_DIRS}) include_directories(${OpenCL_INCLUDE_DIRS}) include_directories(${ZLIB_INCLUDE_DIRS}) +include_directories(${GTEST_INCLUDE_DIRS}) if((UNIX AND NOT APPLE) OR WIN32) include_directories(${BLAS_INCLUDE_DIRS}) @@ -141,7 +142,8 @@ target_link_libraries(tests ${Boost_LIBRARIES}) target_link_libraries(tests ${BLAS_LIBRARIES}) target_link_libraries(tests ${OpenCL_LIBRARIES}) target_link_libraries(tests ${ZLIB_LIBRARIES}) -target_link_libraries(tests gtest_main ${CMAKE_THREAD_LIBS_INIT}) +target_link_libraries(tests ${GTEST_BOTH_LIBRARIES}) +target_link_libraries(tests ${CMAKE_THREAD_LIBS_INIT}) include(GetGitRevisionDescription) git_describe(VERSION --tags) 8dd6ed1'/>
path: root/.mailmap
AgeCommit message (Expand)Author
2020-03-28Update email address and Savannah handle for Amin Bandali....Amin Bandali
2020-02-09Update e-mail address for Jakob L. Kreuze....Tobias Geerinckx-Rice
2020-01-17Update email address for Amin Bandali....Amin Bandali
2019-12-19Update email for Brett Gilio....Brett Gilio
2019-12-18gnu: leocad: Update to 19.07.1....Eric Bavier
2019-05-03Correct email address for ison....ison
2019-03-18Correct name and email address for ng0....ng0
2019-01-21Update .mailmap....Mathieu Othacehe
2018-08-27Update email for Pierre Neidhardt....Pierre Neidhardt
2018-07-16mailmap: Add a line for Pierre-Antoine....Ludovic Courtès
2018-07-16mailmap: Add another line for myself....Nils Gillmann
2018-03-20Correct name and Email for ng0....ng0
2018-02-11mailmap: Adjust entries for ng0....ng0
2017-11-26Update e-mail for ng0....ng0
2017-10-03Update e-mail for Theodoros Foradis....Theodoros Foradis
2017-08-29Update e-mail for Kei Kebreau....Kei Kebreau
2017-08-13mailmap: fix entries for ng0....ng0
2017-06-16mailmap: Adjust entries for ng0....ng0
2017-06-03.mailmap: Add another alias for ng0....ng0