diff --git a/std/socket.d b/std/socket.d index 111cd17..6d23da9 100644 --- a/std/socket.d +++ b/std/socket.d @@ -448,7 +448,7 @@ class Protocol // Skip this test on Android because getprotobyname/number are // unimplemented in bionic. version(CRuntime_Bionic) {} else -@safe unittest +@safe version(hasNetwork) unittest { // import std.stdio : writefln; softUnittest({ @@ -770,7 +770,7 @@ class InternetHost } /// -@safe unittest +@safe version(hasNetwork) unittest { InternetHost ih = new InternetHost; href='/guix/'>guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/mcron.scm
AgeCommit message (Expand)Author
2020-08-26services: mcron: Validate jobs even in the presence of #:user....Ludovic Courtès
2020-08-26services: mcron: Validate jobs at build time....Ludovic Courtès
2020-01-06Adjust module autoloads....Ludovic Courtès
2019-12-08services: mcron: Add description....Robert Vollmert
2019-06-15services: Remove unneeded imports that led to cycles....Ludovic Courtès
2019-05-12services: mcron: Log to a file....Christopher Baines