Patch taken from the Sage packaging system. --- src/include/Lcommon.h 2010-01-31 15:16:45.000000000 +0000 +++ src/include/Lcommon.h 2011-03-08 21:19:11.849443238 +0000 @@ -25,7 +25,7 @@ #ifdef USE_MPFR inline double lcalc_to_double(const double& x) { return x; } #endif -//inline double lcalc_to_double(const long double& x) { return x; } +inline double lcalc_to_double(const long double& x) { return x; } inline double lcalc_to_double(const int& x) { return x; } inline double lcalc_to_double(const long long& x) { return x; } inline double lcalc_to_double(const short& x) { return x; } form method='get'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/databases.scm
AgeCommit message (Expand)Author
2023-05-06tests: Add missing module imports for marionette-evaluated code....Ludovic Courtès
2022-11-20gnu: MariaDB: Update to 10.10.2....Marius Bakke
2022-11-20tests: mysql: Wait for the socket before running queries....Marius Bakke
2022-01-29tests: Add system test for TimescaleDB....Marius Bakke
2022-01-29tests: postgresql: Test the default PostgreSQL....Marius Bakke
2021-09-27services: database: Change postgresql default socket....Mathieu Othacehe
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-04-13tests: postgresql: Fix it....Mathieu Othacehe
2021-03-16gnu: Remove MongoDB....Léo Le Bouter
2021-01-28services: postgresql: Add postgresql-role-service-type....Mathieu Othacehe
2021-01-28services: postgresql: Add log directory support....Mathieu Othacehe
2021-01-28services: postgresql: Use Guile datatypes....Mathieu Othacehe
2020-11-28services: MySQL: Add more tests....Marius Bakke
2020-11-28services: MySQL: Upgrade database schemas automatically....Marius Bakke
2020-11-28services: MySQL: Deprecate 'mysql-service'....Marius Bakke
2020-10-20services: databases: Don't specify a default postgresql version....Christopher Baines