Patch taken from the Sage packaging system. --- lcalc-1.23/include/Lgamma.h 2012-08-08 23:21:55.000000000 +0200 +++ lcalc-1.23/include/Lgamma.h 2014-05-18 21:15:27.786889718 +0200 @@ -77,7 +77,7 @@ //n=0 should just give log_GAMMA(z)... thus making log_GAMMA //code obsolete. But leave log_GAMMA intact anyways. template -precise(ttype) log_GAMMA (ttype z,int n=0) +precise(ttype) log_GAMMA (ttype z,int n) { int M; precise(ttype) log_G,r,r2,y; @@ -230,7 +230,7 @@ //value exp_w which holds exp(-w) //computes G(z,w), so there's an extra w^(-z) factor. template -Complex inc_GAMMA (ttype z,ttype w, const char *method="temme", ttype exp_w = 0, bool recycle=false) +Complex inc_GAMMA (ttype z,ttype w, const char *method, ttype exp_w, bool recycle) { Complex G; @@ -334,7 +334,7 @@ template -ttype cfrac_GAMMA (ttype z,ttype w, ttype exp_w=0, bool recycle=false) //computes G(z,w) via continued fraction +ttype cfrac_GAMMA (ttype z,ttype w, ttype exp_w, bool recycle) //computes G(z,w) via continued fraction { ttype G; @@ -424,7 +424,7 @@ } template -ttype asympt_GAMMA (ttype z,ttype w, ttype exp_w = 0, bool recycle=false) //computes G(z,w) via asymptotic series +ttype asympt_GAMMA (ttype z,ttype w, ttype exp_w, bool recycle) //computes G(z,w) via asymptotic series { if(my_verbose>3) cout << "called asympt_GAMMA("< -ttype comp_inc_GAMMA (ttype z,ttype w,ttype exp_w = 0, bool recycle=false) //computes g(z,w) +ttype comp_inc_GAMMA (ttype z,ttype w,ttype exp_w, bool recycle) //computes g(z,w) { ttype g; @@ -604,7 +604,7 @@ } template -Complex gamma_sum(Complex s, int what_type, ttype *coeff, int N, Double g, Complex l, Double Q, Long Period, Complex delta=1, const char *method="temme") +Complex gamma_sum(Complex s, int what_type, ttype *coeff, int N, Double g, Complex l, Double Q, Long Period, Complex delta, const char *method) { Complex SUM=0; /gnu?id=4d79f072cc7b502fc25486d514c9200ba684a596'>gnu/tests/ssh.scm
AgeCommit message (Expand)Author
2020-04-21tests: ssh: Explicitly wait for port 22....Ludovic Courtès
2019-05-09services: Log-in services now require "pam_loginuid"....Ludovic Courtès
2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès
2018-06-13tests: Honor the return value of 'start-service'....Clément Lassieur
2018-06-01tests: ssh: Use 'with-extensions'....Ludovic Courtès
2017-11-01tests: ssh: Make sure we can run executables from PATH....Marius Bakke
2017-07-23Merge branch 'master' into core-updatesLeo Famulari
2017-07-20tests: Use 'virtual-machine' records instead of monadic procedures....Ludovic Courtès
2017-07-18tests: ssh: Use 'guile-ssh'....Ludovic Courtès
2017-06-12marionette: Factorize 'wait-for-file'....Ludovic Courtès
2017-05-21tests: ssh: Use 'guile2.0-ssh'....Ludovic Courtès
2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès
2017-03-21tests: ssh: Add a test for SFTP....Clément Lassieur
2017-03-21tests: ssh: Abstract session connection and authentication....Clément Lassieur
2016-10-03tests: ssh: Add Dropbear test....Ludovic Courtès
2016-10-03tests: ssh: Generalize....Ludovic Courtès
2016-10-03tests: Add 'openssh-service-type' test....Ludovic Courtès