Git commit c02d59aa6d314678cef9683f96b28e2a1abd82b7 by Andrius Štikonas, on behalf of Hartmut Goebel. Committed on 07/11/2019 at 22:16. Pushed by stikonas into branch '4.0'. Fix test for kpmcore: stop helper only if formerly started. See https://bugs.kde.org/413851 and https://phabricator.kde.org/D25161 diff --git a/src/util/externalcommand.cpp b/src/util/externalcommand.cpp --- a/src/util/externalcommand.cpp +++ b/src/util/externalcommand.cpp @@ -433,14 +433,17 @@ void ExternalCommand::stopHelper() { + if (!helperStarted) + return; auto *interface = new org::kde::kpmcore::externalcommand(QStringLiteral("org.kde.kpmcore.externalcommand"), QStringLiteral("/Helper"), QDBusConnection::systemBus()); QByteArray request; const quint64 nonce = interface->getNonce(); request.setNum(nonce); QByteArray hash = QCryptographicHash::hash(request, QCryptographicHash::Sha512); interface->exit(privateKey->signMessage(hash, QCA::EMSA3_Raw), nonce); + helperStarted = false; delete privateKey; delete init; } yrefslogtreecommitdiff
path: root/gnu/installer/newt.scm
AgeCommit message (Expand)Author
2020-11-07installer: Limit listbox height....Mathieu Othacehe
2020-09-21installer: Rename RUN-PARTIONING-PAGE....Tobias Geerinckx-Rice
2020-04-08installer: Turn help menu into parameters menu....Mathieu Othacehe
2020-04-06installer: Add a help page....Mathieu Othacehe
2019-01-17installer: Clear screen upon exit....Mathieu Othacehe
2019-01-17installer: Display an eventual backtrace in a page....Mathieu Othacehe
2019-01-17installer: Add partitioning support....Mathieu Othacehe
2019-01-17installer: Add services page....Mathieu Othacehe
2019-01-17installer: Do not ask for keyboard model....Mathieu Othacehe
2019-01-17installer: Add configuration formatter....Mathieu Othacehe
2019-01-17installer: Move everything to the build side....Mathieu Othacehe
2019-01-17installer: newt: Locate the logo within local-file....Mathieu Othacehe
2019-01-17installer: newt: Use scheme-modules* instead of scheme-modules....Mathieu Othacehe
2019-01-17gnu: Add graphical installer support....Mathieu Othacehe