diff --git a/src/kpackage/package.cpp b/src/kpackage/package.cpp index 5aec9fd..b15c933 100644 --- a/src/kpackage/package.cpp +++ b/src/kpackage/package.cpp @@ -820,7 +820,7 @@ PackagePrivate::PackagePrivate() : QSharedData(), fallbackPackage(nullptr), metadata(nullptr), - externalPaths(false), + externalPaths(true), valid(false), checkedValid(false) { ps://git.koszko.org/cgit-static/cgit.png' alt='cgit logo'/> index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/syscalls.scm
AgeCommit message (Expand)Author
2021-10-26syscalls: Add 'openpty' and 'login-tty'....* guix/build/syscalls.scm (openpty, login-pty): New procedures. * tests/syscalls.scm ("openpty", "openpty + login-tty"): New tests. Ludovic Courtès
2021-02-25syscalls: Add 'mounts' and the <mount> record type....* guix/build/syscalls.scm (<mount>): New record type. (option-string->mount-flags, mount-flags) (octal-decode, mounts): New procedures. (mount-points): Rewrite in terms of 'mount'. * tests/syscalls.scm ("mounts"): New test. Ludovic Courtès
2020-06-28tests: Do not fail when network interface aliases are present....Fixes <https://bugs.gnu.org/42111>. * tests/syscalls.scm ("network-interface-names"): Filter interface names with a colon. Marius Bakke
2020-06-05tests: syscall: Support file-systems without extended attributes....* tests/syscalls.scm (setxattr): Catch ENOTSUP that can be raised if the file-system does not support extended user attributes. Mathieu Othacehe
2020-06-02tests: Allow passing on systems without support for swap devices....* tests/syscalls.scm ("swapon", "swapoff"): Accept ENOSYS as a valid result. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Simon South
2020-05-14syscalls: Add 'getxattr'....* guix/build/syscalls.scm (getxattr): New procedure. * tests/syscalls.scm ("getxattr, setxattr"): Test it, together with setxattr. Jan (janneke) Nieuwenhuizen
2020-02-11syscalls: Re-enable 'pivot-root' test....Fixes <https://bugs.gnu.org/25476>. Reported by Paul Garlick <pgarlick@tourbillion-technology.com>. * tests/syscalls.scm ("pivot-root"): Skip only when PERFORM-CONTAINER-TESTS? is true. Rewrite to use a socket pair instead of a pipe. Synchronize parent and child so that the parent can initialize the child's UID and GID mappings before continuing. Ludovic Courtès
2019-10-05syscalls: Add 'add-to-entropy-count'....* guix/build/syscalls.scm (RNDADDTOENTCNT): New variable. (add-to-entropy-count): New procedure. * tests/syscalls.scm ("add-to-entropy-count"): New test. Ludovic Courtès
2019-06-27syscalls: Add 'terminal-rows'....* guix/build/syscalls.scm (terminal-dimension): New procedure. (terminal-columns): Rewrite in terms of 'terminal-dimension'. (terminal-rows): New procedure. * tests/syscalls.scm ("terminal-rows"): New test. Ludovic Courtès
2018-07-03syscalls: Define AT_SYMLINK_NOFOLLOW et al....* guix/build/syscalls.scm (AT_FDCWD, AT_SYMLINK_NOFOLLOW, AT_REMOVEDIR) (AT_SYMLINK_FOLLOW, AT_NO_AUTOMOUNT, AT_EMPTY_PATH): New variables. * tests/syscalls.scm ("utime with AT_SYMLINK_NOFOLLOW"): New test. Ludovic Courtès