Kodi doesn't set the CAPATH and CAINFO parameters for libcurl. To make HTTPS
connections work we can set them based on SSL_CERT_DIR and SSL_CERT_FILE.
--- a/xbmc/filesystem/CurlFile.cpp
+++ b/xbmc/filesystem/CurlFile.cpp
@@ -626,8 +626,12 @@
if (!m_cipherlist.empty())
g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str());
+ // Load certificate data from environment paths
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAPATH, getenv("SSL_CERT_DIR"));
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAINFO, getenv("SSL_CERT_FILE"));
+
if (CServiceBroker::GetSettingsComponent()->GetAdvancedSettings()->m_curlDisableHTTP2)
g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
else
// enable HTTP2 support. default: CURL_HTTP_VERSION_1_1. Curl >= 7.62.0 defaults to CURL_HTTP_VERSION_2TLS
g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2TLS);
able class='tabs'>
aboutsummaryrefslogtreecommitdiff |
|
Age | Commit message (Expand) | Author |
2023-11-19 | gnu: tbb: Fix building on powerpc-linux....* gnu/packages/tbb.scm (tbb)[arguments]: Adjust configure-flags when
building for powerpc-linux to always link to libatomic and use the low
resources tests. When building for powerpc-linux skip 3 tests.
Change-Id: I323db085db1fcbb33f96c2bccb85cb8f56d41f6b
| Efraim Flashner |
2023-11-15 | gnu: tbb: Fix building on armhf-linux....* gnu/packages/tbb.scm (tbb)[arguments]: Add configure-flag when
building for armhf-linux to run a lighter test suite. Add a phase when
building for armhf-linux to skip a test.
Change-Id: Ic730c82f30357d3a55e92098114a9dc2a6d062e9
| Efraim Flashner |